Black screen on startx Xorg 1.14.4 fedora 20 x86_64 geforce gt 530 + intel h61 express mobo

Fedora 20 x86_64, kernel 3.13.9-200
Xorg 1.14.4
GeForce GT 530 pci-express card
Asus cm8630 (motherboard uses intel h61 express chipset)

Using any of: latest beta driver (3.37.12), stable 331 driver, or distro-provided (rpmfusion for fedora 20), same situation. Black screen, no response to ctrl-alt-F2/F3/F4/…

When launching X with Nouveau driver, everything is fine.

nvidia bug report attached

Some help here would be nice!

Thank you,
-Caleb
nvidia-bug-report.log.gz (112 KB)

Did you try the “nomodeset” kernel parameter ?

You’ve probably mess your xorg.conf by running nvidia-xconfig which is not needed and breaks the default configuration.

Better to uninstall the packaged driver, uninstall the nvidia binary , remove /etc/X11/xorg.conf and re-install properly following the Official RPM Fusion Howto for nvidia: http://rpmfusion.org/Howto/nVidia

I tried both suggestions - than you both for trying, didierm and nchauvet.

(FYI, I’ve been shutting down with ‘shutdown -h now’, turning off my display, and hard-booting back on between every attempt)

I managed to get much father along with the latest beta and ‘nomodeset’ kernel command line. For awhile, X would actually start, I could bring up apps (in 1024x768), and launch the nvidia gui control panel thingey.

However, trying to get to the spot where I can set resolution, after a few click actions, the mouse slowly became unresponsive, and trying to change resolutions (when it actually got that far) would cause X to crash.

I tried the ‘-uninstall’ procedure with ‘NVIDIA-Linux-x86_64-337.12.run’, deleted /etc/X11/xorg.conf, rebooted, and used yum to install the rpmfusion driver (yum install akmod-nvidia “kernel-devel-uname-r == $(uname -r)”)

at various points, examining /var/log/Xorg.0.log showed ‘WAIT’ errors - kinda looks like some sort of race condition or event loop overflow. Right now I’m getting:

[ 440.518] Loading extension NV-GLX
[ 444.518] (EE) NVIDIA(GPU-0): WAIT: (E, 0, 0x857d)

Anyone else have anything I might try?

Thanks again,
-Caleb

Are you on optimus ? In which case the packaged RPM Fusion driver doesn’t support that.
Better to stay safe using nouveau for now despite it might be supported by the nvidia installer and the appropriate options.

If not please provide the output of nvidia-bug-report.sh with this new setup

OK here is the bug report with the rpmfusion driver installed (but without the ‘nomodeset’ kernel parameter).

I don’t believe this is an optimus switching graphics chips system - it does have an integrated intel chip, but asus support says that it should disable on detection of a different card.

-Caleb
nvidia-bug-report.log.gz (87.5 KB)

[ 57.604723] nvidia 0000:01:00.0: irq 59 for MSI/MSI-X
[ 58.796849] NVRM: GPU at 0000:01:00: GPU-66d6cb8a-158e-bfc2-da02-b1b2df855377
[ 58.796861] NVRM: Xid (0000:01:00): 62, !0099(1628)
[ 66.144181] [sched_delayed] sched: RT throttling activated
[ 107.252769] NVRM: Xid (0000:01:00): 16, Head 00000000 Count 00000002
[ 115.272597] NVRM: Xid (0000:01:00): 16, Head 00000000 Count 00000003
[ 123.270768] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[ 123.292429] NVRM: Xid (0000:01:00): 16, Head 00000000 Count 00000004
[ 131.312258] NVRM: Xid (0000:01:00): 16, Head 00000000 Count 00000005

This is probably something related to the nvidia binary driver. Everything looks fine WRT the packaging.

You might try to look at any bios update for your mainboard.