Blank Screen, no Xorg.0.log, RHEL 7 Beta, Geforce GTX 675M, Samsung NP700G7C-S01US

Hardware: GeForce GTX 675M on a Samsung Series 7 Gamer (NP700G7C-S01US)
Driver: 331.49 and 334.25 both exhibit this problem.
Operating System: RedHat Enterprise Linux 7 Beta x86_64 (based off of Fedora 19)

After an apparently successful installation of the NVIDIA graphics drivers (no errors reported by the installation tool, nouveau successfully disabled, and success report from the installer, with an appropriate Xorg.conf file created), after rebooting the machine to see if things work, the screen goes completely blank when attempting to launch the X server, the fan begins to speed up, and the system completely locks up, with no access to it in any way, no keyboard response, or response to the power button. The system sits there for a while before it will do a hard shutdown, likely due to an overheating issue with the graphics card.

The RHEL 7 Beta has a 3.10.0 kernel (3.10.0-54.0.1.el7.x86_64), and the following thread seems relevant:

https://devtalk.nvidia.com/default/topic/567297/linux/linux-3-10-driver-crash/1/

However, that thread does not address the actual issue with the 3.10 kernel, and instead just talks about updated kernels as the thread progresses. RHEL 7 is likely to stay with the 3.10 series as the kernel is receiving long term support, and as such I would like to continue to use this kernel, as it is the one that is supported by RedHat.

At the moment the nouveau drivers work, but I am trying to do Cuda programming on this machine, and this cannot be done without the NVIDIA graphics drivers, so this is a bit of a problem for me.

I attempted this same installation with the same drivers, but with different Linux distributions, including Slackware64 14.1 (Kernel 3.10.17) and OpenSUSE 13.1 (Kernel 3.11.X). Both of these systems worked correctly after installation and the drivers did not exhibit the same problems.

There are two possibilities for me here: 1. there is a problem between the kernel and the driver that was fixed in some patch that the Slackware distribution has; or, 2. There is some dependency that is not being served which I need. I cannot get a clear system requirements list for the graphics drivers outside of kernel-devel package, which is already installed, so I do not assume that it is #2. If there is a package that I am missing, it would be nice to know about it.

Finally, I am not able to run the NVIDIA bug reporting tool because the driver locks the entire machine and I am unable to run anything during that time. I did reboot into runlevel 3 to try to get more information. What I found was a completely blank and empty Xorg.0.log file, which is the only information on the log I am able to obtain at the moment. It is not clear why this log is blank. It is possible that the blank nature of the log is because the file was never written to disk after the attempted start, but as there is no way to run other programs on the system after running the X server, there is no way to synchronize the file system and push everything to disk before the hard shutdown occurs.

I would appreciate any assistance that anyone can provide on this issue, I have filed a question with NVIDIA support, but I am hoping that someone here has some more information and can provide some workarounds to make this stuff work.

Since you’ve already tried other distributions that work with updated kernels and the same driver, it seems it’s simply a kernel issue.

Apparently that’s what’s been pointed in the thread you reference as well. My only suggestion would be to switch distribution to one with an updated kernel that works…

Works fine here after disabling selinux

[leigh@main-pc ~]$ uname -r
3.10.0-54.0.1.el7.x86_64
[leigh@main-pc ~]$ getenforce 
Disabled
[leigh@main-pc ~]$ glxinfo |grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTS 450/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 331.38
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4.0 NVIDIA 331.38
OpenGL shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions: