Booting does not complete on Jetson Xavier NX & Quark Carrier - Please complete system configuration setup on the serial port provided by Jetson's

I already connected it to my computer by using that port and completed flashing through SDKManager. However, it requires a UART connection through GPIO pins for booting. Hence; I used PL2303 to convert UART pins to USB in order to connect it to my computer after completing flashing. After that, I started booting with Minicom but it stops by outputting the message “Please complete system configuration setup on the serial port provided by Jetson’s USB device mode connection.”
How can I avoid the error? Or can you recommend me a proper tutorial for booting which is suitable for Quark Carrier.

It looks like you cannot understand what I was trying to say here. Let me give whole steps again.

  1. You use the type C port to flash with SDKmanager → it is correct

  2. You connect the UART pin with PL2303 cable and connect it to your ubuntu host. This is ttyUSB0 on your side.

  3. You see there is a log from ttyUSB0 and tells you to finish the configuration. → yes, it is expected. Not an error.

Then what I ask you to do is please keep the typeC port connected to your host, check if there is an interface /dev/ttyACM0 on your host. If there is, open it with other minicom.

As I said, it has nothing to do with ttyUSB0. They are different interfaces. We use ttyUSB0 to dump the log and ttyACM0 to do system configuration for your first boot.

Okay, now I understand it well, thank you. However, I have one last issue that my computer doesn’t detect any /dev/ttyACM* when I connect it. It doesn’t even see on dmesg when I plug it in.

Is it the port you used to flash the device?

Yes, exactly. In flashing, I triggered the recovery button so the port became viewable but now I’m afraid to do it because it’s already flashed.

Please boot up/reboot device and try to hotplug the type C cable few times and see if anything comes from host dmesg.
Also, please check if cdc_acm is listed in your host “lsmod”.

If there is not, some methods here:

method 1. Please directly contact Connecttech and ask them if their driver package missing some software so that you cannot do the system configuration.

method 2. Try below script and re-flash the board again. It was a debug script I shared year ago. It shall skip the system configuration.

1 Like

Hi @furkan.nargul,

Have you contacted our Tech Team? If you fill out our Support Form, our team will help you troubleshoot and get you up and running.

Let me know if you have any questions!

Thank you very much, 2nd method worked! I passed to the login step but I tried both “nvidia” and “ubuntu” for login and password but they didn’t work. What are the username and password supposed to be?

The username and password should be set by you. There is no default user name.

It requires a localhost login and password as shown below. I tried leaving blank for both but it says “Login incorrect”. The last a few lines are shown below.

��WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
��[ 3.368797] cgroup: cgroup2: unknown option “nsdelegate”
��WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
��[ 4.815549] using random self ethernet address
[ 4.815674] using random host ethernet address
[ 4.846990] random: crng init done
[ 4.847097] random: 7 urandom warning(s) missed due to ratelimiting
[ 5.456046] using random self ethernet address
[ 5.456173] using random host ethernet address
[ 5.991732] CPU4: shutdown
[ 6.040228] CPU5: shutdown

Ubuntu 18.04.5 LTS localhost ttyTCU0

localhost login:

Yes, the username + password is set by you when you use the script from method 2…

sudo ./ -u <usr_name> -p “password”

Fİrstly I used the command below:
sudo ./ -u nvidia -p nvidia

Then, I re-flashed the device. However, it still says “Login incorrect.” Can I fix the problem by setting AutoLogin to True?

Then please contact Connecttech to check this issue. Looks like that script is no longer working.

1 Like

I filled the Support Form. When can you provide an answer? Thank you.

I realized that the problem was being caused by the commands. The following commands didn’t work: “sudo ./ -u nvidia -p nvidia” & “sudo ./ -u nvidia -p nvidia -a”.

I changed it to “sudo ./ -u ubuntu -a” and it worked! Thank you for the great support, WayneWWW!

You better still waiting for ConnectTeach team’s reply for it. As I said, the script is just for debug purpose.

The script worked well for debugging. Now I can access the board and use it properly. I haven’t had any problem. Thank you for your support again.

Anyone have any ideas on how to get around this without the debugging script? I am stuck at the same “Please complete system configuration setup” step and cannot get past it.

Connect a monitor to your jetson and follow the instructions over the screen…

If you don’t have a monitor, use your x64 host machine to open /dev/ttyACM0 with micro usb cable connect to tegra.