Buffer has no PTS when running 2 pipelines from same source

Hardware Platform: Jetson Nano
DeepStream Version: 5.1
Issue Type: question

I have 1 pipeline that reads from a camera ( https://www.dropbox.com/s/wyo14n52zgyl5dw/camera-pipeline.png?dl=0 )
1 pipeline that saves the camera stream to disk ( https://www.dropbox.com/s/kbdunnm7utdahji/disk-pipeline.png?dl=0 )
1 pipeline that runs an inference model on the camera ( https://www.dropbox.com/s/xamdn0ej0wkalah/inference-pipeline.created.png?dl=0 )

if i connect the camera pipeline to 1 of the 2 other pipelines, it works fine. If i connect it to both i see a

ERROR from element muxer: Could not multiplex stream.
Debugging info: gstqtmux.c(4561): gst_qt_mux_add_buffer (): /GstPipeline:disk-sink-pipelineusb-046d_0825_2821F020-video-index0/GstSplitMuxSink:splitmuxsinkusb-046d_0825_2821F020-video-index0/GstMP4Mux:muxer:
Buffer has no PTS.

I found a topic with the same error where it says i need a nvmultistreamtiler or nvstreamdemux , but i’m confused on why it would work if i run the inference without the disk sink.

How would i go about finding out why i’m receiving this error ?

The error looks to be from the second pipeline. The default muxer in splitmuxsink is mp4mux. We would suggest try qtmux, or matroskamux to get MKV files.

And please enable insert-sps-pps in nvv4l2h265enc. SPS/PPS information is required in splitting h265 stream.

If it still does not work, please check if saving to h265 stream works:

... ! nvv4l2h265enc ! h265parse ! video/x-h265,stream-format=byte-stream ! filesink location=test.h265

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.