Can I safely ignore those Windows warnings ?

Hi there,

Got 2 Mellanox ConnectX-4 MCX4121A-ACAT NICs installed on a Cisco UCS C240 M5SX with Windows Server 2016.

Events in Windows Server are full of this message :

Mellanox ConnectX 4 dual port 10/25G Ethernet NIC #4 Firmware version 14.24.1602 is below the minimum FW version recommended for this driver.

Minimum recommended Firmware version for this driver: 14.31.392.

It is recommended to upgrade the FW, for more details, please refer to WinOF-2 User Manual.

I tried upgrade the firmware but can’t find the proper firmware since the PSID is Cisco-related.

I had contact with Cisco before this thread and for us, the driver version and firmware version is compatible. It seems that Windows don’t like it.

Cisco will not help me anymore.

I’m wondering if someone had this message before and if I should pay attention to it.

Thanks !

Hello Kévène,

Thank you for posting your question on the Mellanox Community.

When using Mellanox OEM adapters, the OEM is the channel who will provide the certified s/w and f/w for the adapter. When installing the driver from our website, you are running into the issue, that the f/w of the adapter is not being updated as we do not provide OEM adapter f/w in our driver bundle.

It is strange to say that Cisco does not want to assist you any further, as first this is their responsibility and second, it is an easy answer for them to your question.

In your issue, please install the driver bundle provided by Cisco for your OS → https://software.cisco.com/download/home/286318800/type/283853158/release/4.2(1m)

This driver bundles contains the correct f/w version for your PSID. You need to re-install the driver for the adapter through, so the f/w can be updated through the WinOF-2 driver executable.

Thanks and regards,

~Mellanox Technical Support

Hi Martijn and thanks for your answer.

Done, but unfortunately, this updates the driver but not the firmware, so the warning remains.

Can you help me about this ?

Thanks !