Can not update firmware when setting up Jetson Orin Nano

I am trying to set up a brand new Jetson Orin Nano Developer Kit with the following instructions:

I connected the DisplayPort, keyboard, and mouse. I then powered the Jetson with the included DC power supply.

I opened the UEFI menu and saw the version number 3.0 under “Not Specified”. With that information, I deduced that I needed to update the firmware.

I downloaded the Jetpack 5.1.3 image from the download link on the page and flashed it to a 64GB SD card using Balena Etcher

I unplugged the Jetson, inserted the SD card into the Jetson, then plugged it back in. The Nvidia splash screen came on for a few seconds, then everything went black and the screen would not come back. The green light on the jetson was still on and the fan was still running.

I unplugged the Jetson then plugged it back in and I got the same issue, but it looks like the firmware version is now 5.0. I cycled the power several times and got the same issue.

Here is a picture of the splash screen before it crashes

Please find a Ubuntu host PC and use SDK Manager to re-flash everything.

Can I use a virtual machine as the host?

I installed SDK manager on my Ubuntu PC. I connected it to the Jetson Nano. How do I re-flash everything?

Check this post:
https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/

I am stuck on step 4, I keep getting installation failures

Here are the logs
SDKM_logs_JetPack_5.1.3_Linux_for_Jetson_Orin_Nano_modules_2024-06-04_17-42-24.zip (287.7 KB)

[   1.7711 ] Sending bct_br
[   1.7721 ] ERROR: might be timeout in USB write.
Error: Return value 3

Check this post:

I was able to flash Jetpack 5.1.3 using a Ubuntu PC. I’m supposed to check that the current version of nvbootctl is 35.5.0 with this command:

sudo nvbootctrl dump-slots-info

However, when I run the command I get the following result

Current version: 0.0.1
Capsule update status: 0
Current bootloader slot: A
Active bootloader slot: A
num_slots: 2
slot: 0,             status: normal
slot: 1,             status: normal

According to this result, my firmware is not up to date.

I tried rebooting after 5 minutes but I get the same result. Is it safe to proceed? What are the next steps?

Booting log also tells you the bootloader version.

How do I do that?

Put the log here.

It’s here
bootlog.txt (207.2 KB)

Jetson UEFI firmware (version 5.0-35550185 built on 2024-02-20T04:21:22+00:00)

This tells you the bootloader version has been updated to 35.5.

Does this mean it’s safe to proceed to the next step (update the QSPI)?

If you mean updating to JetPack 6, then YES.