Jetson Orin Nano won't update from 3.x to 5.x firmware

Hello, I’m hoping someone can help me with my issue in setting up my Jetson Orin Nano. The firmware of my board is at 3.x. I’ve successfully followed the steps 1 thru 3 in 🚅 Initial Setup Guide - Jeton Orin Nano 🆕 - NVIDIA Jetson AI Lab , including seeing the nvidia-l4t-bootloader Post Install Notification window. But upon reboot, step 4, the firmware never updates to the next version 5.x. Does anyone know what I need to do? Thx

What do “3.x” and “5.x” mean here? Actually there is no such version on Jetson at all…

Thanks for checking in. The UEFI firmware is showing as 3.0-32616947. As I understand from the instructions, by flashing the SD card with JetPack 5.1.3 image (which I did) and going through the process, it will cause the board to update the firmware to 5.0-35550185 (so that I can finally get the board up to version 36.3 and be able to use JetPack 6.0). When I reboot the board, it never updates from 3.0-32616947 to 5.0-35550185. I believe I followed the procedure outlined by cyato’s solution to this issue.

Does this make sense? I’m not sure why this isn’t working.

I think we were having the same issue.

  • Flash 5.12 or 5.13 on to SD card on Jetson Orin Nano.
  • Notification pops up on l4t bootloader updates; requires reboot
  • attempt reboot and nothing happens.

running sudo apt upgrade should download some updates and then run sudo reboot to reboot the jetson. Then you should see the same progress bar for the updates. After this you should be able to see the updated firmware in the boot screen up the top.

From here you can follow instructions for downloading the QSPI updates. install these and then reboot again. Once this install is done you wont be able to boot 5.12+. You’ll need to install 6.0 on your SD card and then boot up with the new firmware and your new SD card. Hope this is of some help.

4 Likes
  • attempt reboot and nothing happens.

Sorry, are you talking about the " l4t bootloader updates" are done but there is no effect?

running sudo apt upgrade should download some updates and then run sudo reboot to reboot the jetson.

This works for me. Thanks!!!
Do you know the reason?

The reason is " running sudo apt upgrade" will upgrade the L4T bootloader.

But I expected insert sdcard will do the same work in background.

@m3rabb Do you have nvme or any other boot drive connected on your device? That would affect the process.

Yes.
The Jetson gives a notification that the l4t bootloader updates require a reboot; I had tried sudo reboot and just manually turning off the power to the Jetson; But for each case the same l4t bootloader updates require reboot would pop up.

For additional context:
I had not installed any nvme at this point. The only reasonable departure from a fresh, out of the box install that I had, was a prior installation of 5.12 to a different SD card via the Nvidia SDK manager. This worked successfully at first but later the OS did not act as expected; I think specifically something to do with a linux utils error; caused the browser to crash and any updates to fail. So I did a fresh install of 5.13 on a new SD card. I don’t have a deep enough understanding of the jetson to know if these two events are related. Might be corroborated if others having this problem had tried something similar, prior to having the same problem.

Hi neil57,

The perquisites to using SD to update bootloader is that the bootloader in QSPI is older than the one from SD image.
Could you check if the following workflow works?
Step 1. Insert SD Card and run the following command to flash both QSPI and SD with R35.3.1

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device mmcblk0p1 -c tools/kernel_flash/flash_l4t_t234_nvme.xml \
-p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit internal

Step 2. Prepare another SD card with SD image of R35.5.0
Step 3. Replace the SD card with the one created in Step2
Step 4. Check if the bootloader in QSPI get update after you run reboot command

I have a Jetson Orin nano board has the 3.x firmware. I have flashed the Jetpack5.13, Completed the initial setup and I am getting thel4t boot loader notification to reboot. The reboot is not updating the firmware for some reasons. I have tried the sudo apt upgrade and sudo reboot. This is also not working. I am getting the same popup again and no firmware upgrade during reboot.

Do you have any log to share?

It won’t provide much help by only telling symptom only.

@WayneWWW, I am new to the nvidia jetson. Could you please share the procedure to take the logs? In order to run the sudo apt upgrade, Does the board requires active internet connection. I cant able to provide the internet connection as the device is not getting connected to my WiFi hotspot or to the ethernet.

Hi,

This method will dump all the log starting from boot. Not only linux kernel but also bootloader log.

@WayneWWW, Thanks for sharing this. I will take the logs and share it here if issue persists. I have another query with this. Does the board requires active internet connection do install the firmware during reboot?

If you are talking about sudo apt-get upgrade, then yes, that one needs ethernet connection.

Thanks, It is resolved now. I updated the firmware to 5.x