Jetson Orin Nano doesn't boot after updated to 5.0 (JetPack 5.1.3)

Hello,

I just got my Jetson Orin nano and was following the start up guide 🚅 Initial Setup Guide - Jeton Orin Nano 🆕 - NVIDIA Jetson AI Lab

I have made an SD card image with the JetPack 5.1.3 and could see the update progress. A When I start the jetson now I get the screen with Nvida logo and EFI stub messages but few seconds later the screen goes off.

Her is the screen

As I understood from the start up guide the jetson should boot into linux with UI after the update… or did I ge tit wrong? Please help the beginner :)
Best regards,
Anton

Please find a Ubuntu host PC and re-flash your device with SDK Manager as instructed:
https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

I have same problem. I also have the same UEFI firmware.
Could it be a problem with the product?

Thanks for the hint, DaveYYY. Somehow it didn’t work for me. If I choose “Manual setup” in recovery mode as it is written in the guidance, the “Flash” button never gets active.

If I choose “Automatic mode”, I get an error right after I press the Flash button. I have tried to choose SD Card and Nvme but this doesn’t make any difference.

I connected pin 9 and pin 10 and it looks like the SDK Manager detects and connects to my Jetson Orin Nano. I have tried to remove the 9 and pin 10 connection and also leave it and see what happens but the “Flash” button never gets activated.

I’ll appreciate any hints regarding how I can move forward.

Best Regards,
Anton

Any progress on your side? I got stuck so far.

Finally it went well and I could flash. The pin 9 and pin 10 are really hard to access, I guess my jumper didn’t work well. Thanks for help!

is it working well when using Jetson SDK Manager?