Can NVIDIA help me navigate the font on the newest jet pack?

I got a jetson nano 2gb to experiment. I built a UI using teinter
On the regular jetson nano. It worked fine.

Now on the new 2gb model with latest jet pack,
Only a flying ant can read the size of the font of not only my UI but also files in the OS explorer. Take a look.

What number microscope objective should i get to
be able to read this?

Thé customise look and appearance does not work!!
Only desktop icons are enlarged

How could a company just ignore this and put this in production?

My screen is 1920x1080

Here’s more! What a shame!

Hi,

Please be calm and clarify what is the exact scenario to hit this issue.

You create a UI and you see the font is very small? But the default desktop UI from jetpack does not have such small font?

I just checked some report. We tried to test this but unfortunately it didn’t happen.

Could you share us what monitor is in use on your side? Also, which jetpack release is in use?

Font is often related to environment. What do you see from this when using the GUI? You can copy and paste even if the font isn’t large enough to be read:

echo $DESKTOP_SESSION
echo $LANG
head -n 1 /etc/nv_tegra_release
ls -l /usr/bin/sudo
# These probably have a lot of output:
env | grep -i 'lxde'
dpkg -l | grep -i font
fc-list

Also, attach a copy of “/var/log/Xorg.0.log”. Some of the output is a bit long, so when pasting it you could paste it to a file and attach the file, or you could highlight it in the thread and click on the “code” icon (looks like “</>”) to add scrollbars and preserve formatting.

Fonts are actually one of the more complicated topics and hard to debug, especially when using different environments.

Hi Wayne I did some tests and the fonts and icons on 1080p on one monitor is not the same 1080p on another monitor. A tv screen at native 1080p also shows different sized icons.

I tried it on a 4K screen downsized to 1080p and the scaling of the text is not the same as scaling on a native 1080p screen

I tired the same tests with my jetson Xavier which has the latest jet pack sometime in December. This one uses Gnome as the desktop and the application fonts and system fonts are fine. Scaling is very good and ports to TVs correctly

Im guessing LXDE desktop has some issues.

What are the risks of i try install another desktop on the jetson nano 2GB?

Hi,
You may try to run gdm3, please refer to this post and give it a try:
Enable lightdm and LXDE - #7 by WayneWWW

However, it consumers more RAM and may impact stability. Please note this.