Enlarged fonts and display on Jetson Nano

After I accidentally pull out the pi camera while the Jetson Nano is running, the screen fonts and outlay is enlarged. What damage would have been inflicted upon? And how to check the source of the problems and fix them? Your help is appreciated!

Can you have a screen shot to show it.
Can it recovery by reflash the Nano?


That’s the first thing that I did, reflashing the SD card. No luck, though.
I’m afraid some chips related to the screen display are busted.
One more thing: When I ran ffplay /dev/video0, it came back with the error: dbus[10645]: arguments to dbus_message_new_method_call() were incorrect, assertion “path != NULL” failed in file …/…/…/dbus/dbus-message.c line 1362.
This is normally a bug in some application using the D-Bus library.

D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

Any suggestions?

Hi,

I am not very sure about such issue. Not able to see any error on your screenshot.
Is changing the appearance and display resolution in system setting helps?

I am glad that the hardware might not be damaged. The Jetson Nano is still working and I am installing the jetson inference. Changing the resolutions didn’t to seem to solve the problem. The same thing happened when I installed the wroing library on the Ubunt 14.0 Desktop and the problem went away when I uninstalled the newly installed one. But for this case, even though I flashed the SD, the problems stays on.

As you may notice, the terminal and other icons are much bigger than usual. They are disproportionately huge and are not like before.
And I still do not understand the command, ffplay /dev/video0 is not working. It spits out the error like:
This is normally a bug in some application using the D-Bus library.

D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

It is more like your desktop becomes smaller instead of icon becomes larger…

I am using the same display. When I pulled out the Rpi camera, the fonts, the terminal, and other icons became bigger.

And I can not access neither the USB webcam nor the Rpi camera.

And I can not access neither the USB webcam nor the Rpi camera.

That sounds a problem. How about other usb device? Are you still able to use mouse or keyboard?

No problem of using other peripherals.

Maybe you could try to reflash the board with sdkmanager. It would format and reinstall the sdcard. Let’s see if this issue could be resolved.

As for the usb camera issue, please check it again after installing sdkm too.

Thank you for your suggestion. After the flashing, I will get back to you.

Despite several attempts of flashing the SD card, the problem of enlarged screen display didn’t go away. So I bought a brand new Jetson Nano and installed the JetPack 4.3 and the enlarged screen issue went away.

But I still could not access the USB camera. When I tried the script, sudo apt-get install v4l-utils, available in the Running the Live Camera Detection Demo(https://github.com/dusty-nv/jetson-inference/blob/master/docs/detectnet-camera.md),
it ran into the error :
Processing triggers for flash-kernel (3.98ubuntu11~18.04.1) …
Unsupported platform.
dpkg: error processing package flash-kernel (–configure):
installed flash-kernel package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
flash-kernel
E: Sub-process /usr/bin/dpkg returned an error code (1)

On my Jetson Nano, the followings packages are installed:
JetPack -4.3
tensorflow 1.15.0
cv2 4.1.1
tf.test.is_gpu_avalible : True
numpy 1.18.4
matplotlib 3.2.1

Would you please help me access the usb camera?

Is the software you are installing trying to install a different kernel?

If you are using software which wants a particular kernel, then this won’t work. Installing a kernel on arm64 embedded is quite different from installing to a desktop PC (both in architecture and boot requirements). I don’t know enough to tell you how to get around this, but if the problem can be identified as being a failed attempt to install a particular kernel, then you might be able to find workarounds.