JetPack 4.4.1 Production Release with L4T 32.4.4

Recently we released JetPack 4.4.1 supporting the new Jetson Nano 2GB Developer Kit. JetPack 4.4.1 supports Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.4.1 Highlights:

  • Support for Jetson Nano 2GB Developer Kit
  • VPI 0.4 with new algorithms, simplified API and block linear support for PVA and VIC backends.
  • All other features and benefits from JetPack 4.4

JetPack 4.4.1 components:

  • L4T R32.4.4
  • CUDA 10.2
  • cuDNN 8.0.0
  • TensorRT 7.1.3
  • VisionWorks 1.6
  • OpenCV 4.1
  • Vulkan 1.2
  • VPI 0.4 (Developer Preview)
  • Nsight Systems 2020.4
  • Nsight Graphics 2020.1
  • Nsight Compute 2019.3

Install JetPack 4.4.1 using SDK Manager or SD card image (for Jetson Nano 2GB Developer Kit, Jetson Nano Developer Kit and Jetson Xavier NX Developer Kit) or upgrade via Debian package management tool (refer instructions from here)

Visit JetPack 4.4.1 and L4T 32.4.4 page for more details.

JetPack 4.4.1 Release Notes … https://docs.nvidia.com/jetson/jetpack/release-notes/index.html

L4T 32.4.4 Release Notes … https://developer.nvidia.com/jetson-linux-driver-package-release-notes-r3244

Hi,

Just received a Nano 2GB a couple hours ago, used Getting Started guide, downloaded jetson-nano-2gb-jp441-sd-card-image.zip burnt it onto a 64GB sd card, and connected it my TV - TV reports 1080p resolution.

The UI is UNUSABLE ! The fonts are incredibly small!

I opened Chromium and searched how to make fonts bigger (Chromium has properly sized fonts). I found fonts were Sans with a size of 11 (and in a few places, 10), put them on 16… still looks very small!

Not to mention, that I received 2 windows with errors on the first boot process - which I couldn’t read because the font was also too small.

This is frustrating… I was expecting a properly working product from NVIDIA, now I have to fix the linux distro instead of running and learning from the cool demos that are available…

Is there a previous version that has properly sized fonts at 1080p?

I see there is a related issue opened: Initial boot configuration succeeds but unminimize command fails and changes the desktop in a bad way (10/21/2020 Nano Image)
please, please fix this ASAP, this board should be easy-to-use not hard-to-fix-to-use.

Let me know if you need more details, but please try the image above on a TV with 1080p.

Regards,
Adrian

Hi Adrian, sorry about that - let’s see if we can dig into what is happening. As you have discovered, LXDE is the default desktop manager on Nano 2GB (to save memory). I run a 1080p monitor on it here, and haven’t found the fonts to be smaller than the GNOME desktop.

Can you go to Preferences -> Display Settings and confirm that your display is indeed running at 1920x1080?

It sounds like you have found Preferences -> Customize Look and Feel, but if not you can change the Default Font size there.

If you continue to face the issue, can you take a picture or screenshot of your TV running the desktop and post it here? Thanks.

Hi Dusty,

Yes, I can confirm I’ve played under Preferences -> Display Settings also, it was 1080p. TV “info” panel also said 1080p. I even switched to 720p, the same thing… extremely small fonts.

I’m re-burning the SD card and will test tomorrow. I’ll take some pictures and paste them here.

Reagrds,
Adrian.

Note: I can’t upload more than one picture because I’m a new user. I’ll leave one picture showing the small fonts. (I wanted to upload 7)

Hi,

I’ve uploaded some pictures taken durring the setup phase + some showing the small fonts.

In the last image the fonts look right because I’ve added -dpi 96 in /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf. I don’t know if 96 is is the appropriate number or if this is the appropriate fix, but it works for now…

Let me know your thoughts and when there’s a release that fixes this.

Regards,
Adrian.

  • cuDNN 8.0.0

Is the darknet performance-bug fixed here?

I wonder a bit, because cuDNN 8.0.4 is the latest release…

Hello, can I use the image for 2GB nano on my old 4GB nano (A02)? I just want to take advantage of the reduced memory usage, unity is still too heavy for my needs

So it will update via apt?
I have filesystem in a SSD with the jetson_hacks metod, if it will update via apt, will this brake my system?
In that case how is the right way to proceed? I clone my SSD in the SD card, update the sd card to 4.4.1 and later I make again the jetson_hacks script.? There is other easier way?

Hmm, xdpyinfo | grep dots shows that my DPI is already set to 96. I wonder if perhaps the DPI of your TV was higher, or the EDID was being set incorrectly. You could disable your change and then check the default DPI to see. If you continue facing the issue, I recommend posting a new topic about it so one of our display experts can take a deeper look.

Hi @Lars-EK, it appears that cuDNN team is still working on the issue, and not fixed in 8.0.4 yet either. You may want to continue with your workarounds from this post:

https://forums.developer.nvidia.com/t/darknet-slower-using-jetpack-4-4-cudnn-8-0-0-cuda-10-2-than-jetpack-4-3-cudnn-7-6-3-cuda-10-0/121579/23?u=dusty_nv

1 Like

Hi @jose.laruta, you cannot use the Nano 2GB image on the Nano 4GB (or vice versa), because they have different device trees and memory configurations.

However you can install LXDE onto any Jetson, see the procedure here:

Hi @fpsychosis, I’m not personally sure - you may want to post a new topic about this to get wider input from the team and community.

Hi,

adi@nano2g:~$ xdpyinfo | grep dots
  resolution:    33x33 dots per inch

with the -dpi 96 pulled out of /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf

TV is 4K capable and it’s a Philips model: 65PUS6504/12

PS: with -dpi 96 in /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf file, xdpyinfo | grep dots returns 96x96.

I downloaded jetson-nano-2gb-jp441-sd-card-image.zip burnt it onto a 64GB sd card. The light is on after the power is connected but cannot be turned on. what should I do?

Hi,

Just received a Nano 2GB a couple days ago and, downloaded jetson-nano-2gb-jp441-sd-card-image.zip burnt it onto a 32GB sd card. While starting to install Tensorflow 2.x, I found many errors.

I would wondering if I can downgrade Nano2G image to JetPack to 4.3 since my old projects were all using Nano4G based on JetPack4.3 with tensor1.15 ??? I don’t want to upgrade tensorflow version.

Hi @572739554, you might want to try flashing your SD card again or flashing another SD card. If you plug in Ethernet to a switch do you get any status/activity LEDs or the MicroUSB cable to a PC for serial connection? If you attach a USB keyboard, do you get any LEDs from it? Do you have an HDMI monitor connected?

If you still can’t get it to boot up, I would recommend filing a new topic so we can help you further with it.

Hi @jimli081601, JetPack 4.4.1 is the first release to support Nano 2GB (so you can’t downgrade it), however you can install TensorFlow 1.15 for it. See these links for more info:

There are also the l4t-tensorflow containers available for both TF 1.15 and TF 2.x that come with TensorFlow pre-installed in the containers.