Initial boot configuration succeeds but unminimize command fails and changes the desktop in a bad way (10/21/2020 Nano Image)

I am trying to set up my Jetson Nano B01 board with the latest nvidia image ( JetPack 4.4.1 released 10/21/2020) and unminimize the OS.

The initial setup and boot goes fine but when I run the unminimize command it fails and changes the window manager from the one in the initial boot to one I find unusable (openbox-lxde).
By running sudo dpkg --configure -a (as suggested in the unminimize logs) followed by sudo unminimize --fix-missing, I was able to persuade the unminimize process to complete. However, it did not revert the desktop back to it’s state before I ran unminimize.

So my question is, is this supposed to happen to the desktop? I find the fonts unreadably small on my 1920 x 1080 displays. I can’t deduce what is what on the desktop and menus. And I don’t think I should have to spend several hours finding all the places I need to change font sizes to make the desktop usable.

Does anyone have any suggestions for reverting to the original window manager? Should I wait for a new image to be released that fixes unminimize?

I believe we didn’t verify unminimize.

What is the exact steps to hit your error? I don’t quite understand the connection between your problem with openbox-lxde.

Do you mean you’ve replaced the window manager to openbox-lxde and then you tried unminimize command?

I mean that when I rebooted after unminimize failed the window manager was openbox-lxde instead of the normal one.

steps to reproduce:

  1. dd the 10/21/2020 nano 4g image onto an SD card
  2. plug the SD card into the nano and go through the setup process.
    If I reboot here, the window manager has not been changed
  3. sudo unminimize (script aborts before completion)
  4. reboot
    when the system comes back up the window manager is openbox-lxde

I also tried running the recovery steps for unminimize before rebooting
3.1) sudo dpkg --configure -a
3.2) sudo unminimize --fix-missing

and while the recovery steps appeared to work, the window manager was still changed to openbox-lxde


I guess we don’t support this currently. Will check with internal team and see if we can fix this.

Hi jeffleonard0401,

We tried to reproduce issue, but after run “sudo unminimize” and reboot, the device can’t boot up, stuck on NVIDIA logo.

I tried to reproduce again after seeing your message. I get different results than before. Now my nano crashes, reboots itself and comes back up in the other window manager. I have attached a log from running unminimize as well as the syslog. initialboot.tar.gz (144.4 KB)


Please do not use unminimize at this moment. We will check what is going on.

The openbox-lxde is for Nano-2GB product because it will take less memory consumption.
Somehow the unminimize process cause the board to switch display manager to lightdm + lxde.