Menu and Desktop Font / Text Too Small to Read

I have booted up for the first time with my Jetson Nano 2GB and find that the text on the Nvidia desktop and menus to be so small that I am unable to read it and find where to increase the size. I am using a 42" Sony 1080p LED via hdmi. The desktop icons seem to be the standard size but the text and all menu’s and their accompanying text is too small to read. I have tried using gsetting in the terminal to increase the text from a factor of 1.5 to 2.5 and it has no effect on the text size.

Any ideas?

Hi,
Please go to [Preferences] -> [Customize Look and Feel] and adjust the setting.

1 Like

I have the same issue, we don’t see any difference after change every font size under Customize Look and Feel option. Tried multiple times.
Also noticed this occurs only when we select auto login option while installing the OS.

Can you try checking your DPI with xdpyinfo | grep dots ? Mine is 96 (what is actually reported is 93x95)

It seems like some TVs have a lower default DPI which makes the fonts appear smaller. You can change this by adding -dpi 96 in /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf.

For more info, please see this post: https://forums.developer.nvidia.com/t/jetpack-4-4-1-production-release-with-l4t-32-4-4/158279/14?u=dusty_nv

2 Likes

Results of ‘xdpyinfo | grep dots’ - “resolution: 30x30 dots per inch” What is the text editor for this OS? I tried to edit the file you suggested with Nano but it didn’t come up. I literally can’t read any of the labels to figure out what app is what.

Where is [Preferences] -> [Customize Look and Feel] ? I am unable to read anything to figure out where that is. Can you give me a hint? Is it in the “Start” menus? Thanks for the help on this by the way, I really do appreciate it…

k.

You can get to GEdit by going to Start -> Accessories -> Text Editor.

However, if you can’t read any of the text, then it may be easier to SSH in from another system and do the edits that way.

1 Like

Mine was 75 75, the text seem to appear crisp after changing to 96, but the size of the text remains same.
Just to be clear the Desktop icon text can be changed under Desktop Preference.
But the start menu text is what too small.
I am attaching a screenshot for reference.

For me, if I go into Start Menu -> Preferences -> Customize Look and Feel and then increase the default font size, it makes the start menu items bigger.

2 Likes

Got it… It works, I forgot to change this after setting the dpi…
Thank you for your help…
Have a great day…

1 Like

SUCCESS!!! Thanks everyone! You all were a big help collectively. The screenshot helped me feel my way to the ‘Customize Look and Feel’ window. (Couldn’t even read the text enough to find it without the screenshot) Then everyone else pointing that and advising me to change the font size there fixed everything.

Thanks again…

1 Like

Quick Update: I got a bigger SD card and reburned the OS on it and realized that the first SD card was burned with the 4GB Jetson Nano image but I have the new 2GB Jetson Nano. Don’t know if this contributed to the problem with the small font, but the font thing didn’t happen on the new SD card. Just mentioning it if some one comes here and it does contribute to the problem. Could be completely unrelated.

Can you try checking your DPI with xdpyinfo | grep dots ? Mine is 96 (what is actually reported is 93x95)
It seems like some TVs have a lower default DPI which makes the fonts appear smaller. You can change this by adding -dpi 96 in /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf .
For more info, please see this post: https://forums.developer.nvidia.com/t/jetpack-4-4-1-production-release-with-l4t-32-4-4/158279/14?u=dusty_nv

Hi Dusty,

I see some1 reported this again, and probably others will too. Can NVIDIA fix this in the future, so new users have an easier onboarding to the with the Nano learning kits?

We have tested this on TVs internally but have been unable to replicate the issue, sorry about that. It seems limited to some models of TV - we will look into it further.

@dusty_nv
If you want I can setup SSH access towards my Nano 2GB (starting from Thursday) and give NVIDIA full access for a few hours starting from 2PM Santa Clara time.

If not, tell me what else I can help with…

Thank you, I will let the display team know and get back to you if they have additional questions or queries to run to debug the issue.

I had the same problem, Jetson nano 2 GB, fresh install connected to a TV and the letters where too small to read (the same size as the pixels).

I could figure it out, with the solution discussed, but as I was new on linux too, the information given here is not enough to solve it easily. So, I will try to explain in detail what I had to do.

We can use the image of the desktop given on “suhpavn” comment as a reference.

  1. First let’s check our DPI settings.

    • Open the icon with a screen to access a command tool.
    • Type “xdpyinfo | grep dots" to check, I had 25x25, we want to change it to 96.
  2. Changing DPI:

    • Open the icon with a folder
      -Type on the address bar “/usr/share/lightdm/lightdm.conf.d/” and enter to access the folder
    • There are like 6 files, the last one is the one we want to open, open it and check if the name is “50-xserver-command.conf”
    • At this point I had a problem, because the file is read only, you can see this after the file name, or when you try to save it. If this is the case follow step 3 too.
    • To change DPI we have to add “-dpi 96” to the “xserver-command=X -core” line like this “xserver-command=X -core -dpi 96” .
    • Save and restart the Jetson. (Open the bottom left bar, click on the last element, and search for the restart icon). Should be solved after the reboot.
  3. If the file “50-xserver-command.conf” is read only (Step don’t needed otherwise).

    • We have to change the permissions of the file with root permissions.
    • Open the command tool again.
    • Type “cd /usr/share/lightdm/lightdm.conf.d/” to go to the file folder
    • Type “sudo chmod u=rw,g=rw,o=rw 50-xserver-command.conf” ( sudo executes the chmod(or any) command with root access).
    • The command tool will ask for the user password, type it.
    • Permissions should be changed. now you should be able to finish the step 2.
      ( You can check permissions of the file with the command “ls -l 50-xserver-command.conf” ( at command tool, when you are on the correct folder) u is for User, g is for Group, o is for Other. w -> write, r -> read, wr-> write and read)
      ( - If you want, you can revert the permission changes, follow this step but use “sudo chmod u=rw,g=r,o=r 50-xserver-command.conf” )

I hope it will help. I will try to improve the details if needed

I changed my account type to admin, I don’t know if it’s needed too.