Can ping but can not ssh to jetson xavier nx?

I can ping to jetson 192.168.55.1, I can ssh from jetson to PC, but I CAN NOT ssh from PC to Jetson.
This is a message

connection reset by 192.168.55.1 port 22

I tried with different PC and the error is same. Please help me.

Check the status of ssh server on Jetson:

@DaveYYY
Thanks for response.
I tried your methods and many recommends but it did not work.
I reflashed again and the error is solved.
From my experience of working with Jetson Xavier NX. There are “some problems” with flashing Jetson Xavier NX with SDK manager. It is not stable to flash and sometimes we need to trick to workaround it.

I don’t think this is related to Jetson at all.
If it fails with 192.168.55.1, then it should also fail with other IPs that come with a real Ethernet cable.

I also tried ssh from other PC, but it is also failed. Moreover, I tried to connect PC and Jetson to wifi and use IP in wifi to ssh. It is also failed. It is so strange, because I could ping but could not ssh. I checked firewall, it was ok.

I don’t really know what the situation was based on your comment, but it’s fine you solved it.

1 Like

Ok, thank you for quick supporting.

Something to always test if you cannot ssh from outside of a system to inside: Try ssh from the local computer to itself. Example:
ssh 127.0.0.1

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.