Unable to build up connection from host to target via ssh

Hello,
I’m currently facing following problem:
I want to set up and install my Xavier dev kit. I’m working with the installation guidelines of Jetpack 4.1.1 and Jetpack 4.1.1. The installations on the host are working fine, also the flashing of the linux OS on target.
But then the host gets a timeout when installing the required packages on the target (for example CUDA). Also target is not accessible via ssh.
Target shows the correct IP address after boot.
I chose the variant without additional wifi-switch for installation, so that Xavier uses host as bridge.

What could be the problem?

Cheers
Max

Can you ping the address? What do you see if you manually try this:

ssh nvidia@<whateverIPaddress>

(login name nvidia has password “nvidia” by default)

Any error log after ssh failure?
Are you available to access device? You could try to use usb-c for serial console or connect HDMI to it.

hello betzebubi,

could you please also share uart logs,
you may refer to Topic 1043897 to gather uart logs via J501.
thanks

When you are doing the flashing, the Jetpack will ask you to set up Host’s network interface that is connected to the internet, and as long as the Host has the internet connection on the selected interface, the installation should work, in my opinion. [I presume you also choose ‘Jetson connected to Host via USB cable’]
I would encourage you to try again.

Hello,

when trying to build up connection via

ssh nvidia@<whateverIPaddress>

the answer is:

ssh: connect to host <whateverIPaddress> port 22: No route to host
lsusb

shows me that connection is available.

Maybe ssh is not set up correctly on the host?

You would need to replace “” with the actual IP address. “” just stands in for the real address, which I don’t know (it would look something like “192.168.1.2” or “10.0.0.2”…or something similar).

I know how it works, don’t worry, it’s 192.168.55.1.

I tried it also with another host computer and there it works all fine. Any suggestion what could cause the problems on the first host?

This is the USB device “gadget” emulating a network card (this is more or less a demonstration). I have not tried to use this for ssh, but this is probably why it fails.

Your host PC may need to add extra steps to use the USB “gadget” as if it is a real USB network device. It is highly likely that you have a real ethernet interface on your host PC which the combination of address/mask goes to…this would bypass a second network device using the same address/mask combination.

Do you not have a real ethernet network set up? JetPack is expecting the Jetson to use wired ethernet.

My way to fix this,

Create a new ethernet connection with the virtual USB network card. Connect then ssh works to 192.168.55.1