Can sudo jetson_clocks cause DLA to turn off DVFS?If not, how can I fix my DLA clock frequency

After using sudo jetson_clocks, the CPU GPU is fixed to the maximum frequency, but as shown in the image below, I can see that the clock frequency of DLA still fluctuates between 0-1600MHZ. Does this mean that sudo cannot turn off DVFS of DLA?

Another issue is that I can manually specify the clock frequency of the CPU and GPU using the following command(Jetson Orin NX Series and Jetson AGX Orin Series — Jetson Linux<br/>Developer Guide 34.1 documentation
$echo<CPU_ Freq>>/sys/devices/system/cpu/cpu/cpufreq/scaling_ Min_ Freq
$echo<CPU_ Freq>>/sys/devices/system/cpu/cpu/cpufreq/scaling_ Max_ Freq

Is there a way for me to manually specify the clock frequency of DLA?

Correction: “Does this mean that sudo cannot turn off DVFS of DLA?” Correct to “Does this mean that sudo jetson_clocks cannot turn off DVFS of DLA?”

The nvpmodel program selects the range of clocks available. jetson_clocks forces the high end of that particular model. If you use nvpmodel to set the max performance mode, and then set jetson_clocks, you’d disable going to lower frequences, with one exception: Thermal throttling I believe will still run. Normal control methods are not designed to allow the system to “fry” and thermal throttling will still occur.

Thank you very much!
As Is there any performance tunning knobs for DLA? mentioned, do I have any other methods besides using nvbpmodel to adjust the frequency of DLA without the need for a reboot? (after changing the power mode using nvpmodel, a reboot is required)

The way DVFS is controlled is via drivers. Those drivers are exposed as files in “/sys” (they pseudo files). nvpmodel itself just uses echo to send values to the “/sys” files. nvpmodel should not require a reboot. It is true that nvpmodel can write a desired value to a config file for what to boot up to, and in that case the config file would not be read until boot has proceeded to some degree (meaning writing the config file might still need a reboot, but running nvpmodel with a command to change its model should instantly change the model, and then jetson_clocks should instantly boost to that range’s max).

What command are you using? Something like “sudo nvpmodel -m 0” followed by “sudo jetson_clocks” should change the system immediately, although it won’t write a config and a reboot would actually revert.

Thanks for your reply!
The current power mode of the system is 0: MAXN. When I tried to change the power mode to 1: MODE 15w using sudo nvpmode - m 1, the following prompt appeared, reminding me that after changing the power mode, a reboot is required to take effect.

This is something else. Probably @WayneWWW might want to step in. I am wondering, is this a developer kit, or does it have a custom carrier board? I would not expect to see the nvpmodel change require a reboot. I am wondering if (A) something is using the GPU in a way that prevents the power mode change, or perhaps (B) the device tree is setting up this mode during boot stage.

Also, if you do this, does it go into the correct/expected model once reboot completes? If it does, then you can use nvpmodel to save that state once in that state.

Thanks for your reply!
The device I am using is Jetson AGX Orin Developer Kit, as shown in the following image.

When I tried to modify the power mode, the GPU was idle.
After I followed the instructions to restart the device, I was able to successfully modify the power mode.
Perhaps it’s really not possible to change the power mode without restarting.

It should be possible to save nvpmodel setting and have it restore after reboot. You might check out “nvpmodel --help”. Note that you will have an option to get a verbose log with the --verbose option. If you are setting your nvpmodel, e.g., to -m 0 (or anything), and you also add --verbose, does the verbose log show more about why it is asking to reboot? I’m suspicious that something simple is going on and getting in the way.

However, I couldn’t tell you what NVIDIA considers the proper way to restore a non-default nvpmodel upon boot, nor could I tell you why nvpmodel changing to -m 0 would be telling you that you have to reboot. This seems odd.

1 Like

I have reviewed the power documentation(Jetson Orin NX Series and Jetson AGX Orin Series — Jetson Linux<br/>Developer Guide 34.1 documentation, which mentioned that when we switch to the target power mode, When the tpc_pg_mask is different from the current mode, a system restart is required to successfully replace it

From the prompt provided by sudo nvpmodel, it is indeed because of this.

Thank you for your patient answer! I think my problem has now been resolved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.