Can this run on an RTX 3090 with the latest drivers? "Invalid Device Symbol" error

Hi,

I’ve followed the quick start guide, installed everything successfully and installed the latest 455 driver on Ubuntu 20.04 server.

When I try to run the sample in the quick start I get the following:

cudaSafeCall() failed at ParaBricks/src/mem_chain_kernel.cu:148 : invalid device symbol
Please contact Parabricks-Support@nvidia.com for any questions. Exiting...

Could not run fq2bam
Exiting pbrun ...

Hey @robmpreston,

Which GPU are you trying to run on? A100 by any chance?

On the RTX 3090… when will this be supported?

Thanks will try.

Can you paste the exact error and the command you ran?

@gburnett

====================================
Installing Parabricks
Final Selection:
Install Directory:      /opt/parabricks
Install Version:        va2.0
Install Container Type: docker
Install Architecture:   x86_64
registry.gitlab.com
====================================

Are the above installation parameters correct?
Proceed with installation? Type yes or no only: yes

Do you want to create a symlink to /usr/bin/pbrun ?
Proceed with installation? Type yes or no only: yes

Checking curl installation

Checking if image is already present


Downloading image

Cannot contact Parabricks registry.
Contact Parabricks-Support@nvidia.com for troubleshooting
There is a forum for Q&A at https://docs.nvidia.com/clara/parabricks/v3.5/index.html
/usr/bin/docker
Removing login credentials for registry.gitlab.com

hmm… if you are on a trial license, it may have expired. the issue doesn’t seem to be related to your hardware, but to connecting to the Parabricks registry.

I have the same error, but my license just started from 3 days ago
“”"
GPU-BWA mem
ProgressMeter Reads Base Pairs Aligned
cudaSafeCall() failed at ParaBricks/src/mem_chain_kernel.cu:148 : invalid device symbol
Please contact Parabricks-Support@nvidia.com for any questions
There is a forum for Q&A as well at https://forums.developer.nvidia.com/c/healthcare/Parabricks/290
Exiting…

Could not run fq2bam as part of germline pipeline
Exiting pbrun …
“”"
please help me! I ran on server AMD ram 64GB, 16 threads, Nvidia 3090

Did you use --ampere flag with installer ?

When I posted this it didn’t exist, but thats what I use now :)

1 Like