Can we use Nvidia Maxine in Ubuntu 22.04 with Cuda 12.1?

I have a question about using Nvidia Maxine SDK in Ubuntu 22.04 with Cuda 12.1. Is it possible to use this version of OS and Cuda for the development?

Hi BehKal! Welcome to the NVIDIA Developer Forums! Yes, Maxine will run on 22.04 and CUDA 12.1.

Hello Mark. Thank you for your message. I tried to test Video effects SDK in Ubuntu 22.04, with Cuda 12.1, TensorRT and cuDNN 8.9.2. In building the samples I faced an error:

How can I resolve the issue? I would appreciate your assistance.

In addition I modified the default versions (Cuda, TensorRT and cuDNN) for building the samples.

Please give me some time, I would like to test this again on one of my bench machines. I will try to get back to you soon!

Sure. I will be waiting for your reply. The priority is to run NVIDIA Maxine in Ubuntu 22, the CUDA version can be 11.8. Also, I tried it with Cuda Toolkit 11.8 and TensorRT in Ubuntu 22, but I encountered this error:

Thank you.

Thank you, I have not forgotten! I am working on several projects. I should have some time today.

Hello again. Is there any new update about using Maxine in Ubuntu 22.04?

Not at this time, I apologize for the delay. I will work on this as I can. For now I suggest dropping down to 20.04 as I haven’t had time to do a deep dive.

I see. The problem in Ubuntu 20.04 is related to the GStreamer version. GStreamer version is 1.16 in Ubuntu 20.04, and for using the “nvcodec” plugin of Nvidia, I have to use a newer version like GStreamer version 1.20, which is available in Ubuntu 22.04. Upgrading GStreamer version in Ubuntu 20.04 to 1.20 has some negative effects on my project, and I encounter some problems with compatibility.