can1 SockeCAN (CAN6 connector) not working - DRIVE


we are using DRIVE SocketCAN can0, CAN5 connector, works fine at 500kbps.
We wanted to use also can1, CAN6 connector, but SocketCAN is not working:

  • ifconfig shows no stats for can1
  • candump from can-utils of course not showing anything

Has anybody been using can1 successfully in DRIVE

For now we don’t want to go through the Aurix.

However what is also worth mentioning is this:
When using the Aurix terminal and the command canrxlog on, nothing is being displayed. can0 streams fine in linux (CAN5) but no messages displayed in the Aurix terminal. We also tried setting the baudrate cansetbr e 500. Using DPX2-P2379-EB-Aurix-2.02.04.


Tested can1 in both TA and TB.

I updated my Chauffeur board yesterday to do my first tests.
For me the setup worked like this:

Tegra A can0 → CAN5
Tegra B can1 → CAN6

Tegra A can1 and Tegra B can0 both seem not to be connected at all.

I wonder whether there’s any documentation for that - will take a look now.
I terminated both CAN busses with 120 Ohm by now, which was just a try before finding the documentation ;-)