Cannot apply torque in Rigidbody Robot

Hi everyone,

I would like to apply the torque into the body of the robot to make the robot rotate by using “apply_forces_and_torques_at_pos”. When I’m using “apply_forces_and_torques_at_pos” on Isaac 2022.2.1, It worked. But I used Isaac 2022.2.1, I had a problem with Cuda when I wanted to run multi-robot. Then, I updated Isaac to Isaac 2023.1.1. The problem of running multi-robot was solved but the “apply_forces_and_torques_at_pos” it cannot work. I add my code below.

        torch_rol = torch.tensor([[0.0,0.0,self.sum_rolling_moment],[0.0,0.0,self.sum_rolling_moment]], dtype=torch.float32, device=self._device)
        self._copters.physics_bodys.apply_forces_and_torques_at_pos(torques = torch_rol, indices=self.all_indices, is_global=False)

My code didn’t notice the error at the terminal. However, My robot doesn’t move. Is there any way to solve this problem?

Thanks in advance,

It is hard to tell without more information what is wrong in your case if there isn’t any error reported from the terminal. My recommendation is to try to play with the force magnitude and/or mass of the objects to see if it makes any difference

Sorry for late reply.
I attached the script file below. (7.9 KB) (2.2 KB)