Controlling Robots via ROS

Hi,

I’m currently trying to control a Robot via ROS, but with no success so far.
I tried the TurtleBot Sample (ROS TurtleBot3 Sample — Omniverse Robotics documentation) and it works fine. But whatever i try, i can’t get it to work with my own robots. Attached you find a simple Robot i built. It has two wheels and should be comparable to the TurtleBot. Yet - even using the same code as in the sample - it won’t move.
Can somebody help me with that? Thanks a lot!

TestBot5New.usd (6.6 KB)

@chr1s under the PhysicsScene prim set the Enabled GPU Dynamics flag to False and optionally:

  • set the broadphase type to MBP
  • set the solver type to TGS
    Once you press play, the robot should move based on the ros joint commands
    This bug will has been fixed and will be part of the next release, thanks for reporting!

Also you should add mass APIs to the Chassis, wheel_left and wheel_right objects. You can do this via the Property tab Add->Physics-> Mass. Then scroll down and set the mass from autocompute to some realistic value in KG

You can inspect the current mass using Isaac Utils->Inspect Physics and click on the Chassis while simulation is running. (It will show the mass as 1000kg)

Yes that worked, thanks for the help!