Cannot find function NvEglApiGetAccess after installing ROS Kinetic

Hi to everyone,

my team and I are running camera / dnn based object detection on PX2 and want to utilize ROS for our software environment. We are running DW 0.6.54 installed by DriveInstall 5.0.5.

Halfway through writing this text I found the fix for the problem I am describing in the following. I am still posting this for anyone who has the same issue.

Steps to reproduce:

After this I get “Cannot find function NvEglApiGetAccess” followed by Driveworks exception whenever running a program that initializes an image streamer. (samples I tried are sample_camera_gmsl, sample_object_detector etc…).

Workaround: run sudo -i. Then start the sample.

Hope this helps anyone who is possibly struggling with the same issue.

thank you so much!!

Dear FelixB,
Thank you for your sharing.

@FelixB, thanks for the tip, however Running the sample as root isn’t ideal. When you begin to build ROS programs using Driveworks Cameras via their API you’ll find they TOO will have the same error.

Instead Use:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib:/usr/lib/aarch64-linux-gnu

Then your user environment will run the examples and ROS+Driveworks compiled examples together.

Thank you for sharing this information