Cannot flash Jetson AGX orin: "Reading board information failed"

I cannot use the SDK Manager to flash the required JetPack on it. The SDK manager detects the jetson orin but it always says " “Reading board information failed”. (pic attached)

I have the developer kit:
Jetson AGX Orin
P3701-0000 module
P3737-0000 carrier board

The board shows up using $lsusb command:
Bus 003 Device 005: ID 0955:7023 NVIDIA Corp. APX

The entire log can be seen here: SDKM_logs_JetPack_5.0.2_(rev._1) - Google Drive

Log file zip:
SDKM_logs_JetPack_5.0.2_(rev._1) (70.5 KB)

Currently, the device does not boot and does not show up in ifconfig output. Pic of screen during boot attached.


  1. Tried to install cuda 11-8 and it resulted in the display not working. (SSH still worked)
  2. Tried to uninstall cuda 11-8 and then the SSH also stopped working.

Current situation:

  1. Display does not work
  2. SSH does not work
  3. Cannot flash jetpack using jetpack on Host machine laptop (with Ubuntu 20.04)

I would appreciate any help. Thank you so much.


Need your help to dump the log from uart console.


Please dump 2 logs

  1. Boot up the device → log 1

  2. Run the flash command and hit error → log 2.



I was able to see the output of “/dev/ttyACM0” using the command:
sudo cat /dev/ttyACM0

I have attached the log during normal boot.

log1_during_normal_boot.txt (83.3 KB)

However, I cannot see anything on "/dev/ttyACM0 " when the JEtson Orin is in recovery mode.

I have attached the output of SDK manager error:
error_in_sdkm.txt (5.4 KB)

SDKM logs during trying to flash Jetson orin:
SDKM_logs_JetPack_5.0.2_(rev._1) (141.7 KB)

I did try to follow the instructions here:Setting up Minicom Client - Ubuntu - RidgeRun Developer Connection

But there was no output of $ls -al /dev/ttyUSB* :

zsh: no matches found: /dev/ttyUSB*

Whereas for $ls -al /dev/ttyACM* the output was :

crw-rw---- 1 root dialout 166, 0 Oct 25 23:56 /dev/ttyACM0
crw-rw---- 1 root dialout 166, 1 Oct 25 23:56 /dev/ttyACM1
crw-rw---- 1 root dialout 166, 2 Oct 25 23:56 /dev/ttyACM2
crw-rw---- 1 root dialout 166, 3 Oct 25 23:56 /dev/ttyACM3
  1. The boot log is fine. The console is still working.

  2. The flash error seems similar to "WARNING: Test key is used." Board not responsive after installing jetpack 5.0.2 - #5 by WayneWWW

Is that ubuntu20.04 a VM?

Thanks for your help and prompt support.

For your question:
No. I am using my laptop as a host machine to run the SDK manager. It has Ubuntu 20.04. It is not a virtual machine.

When I was trying to uninstall the cuda 11-8, I think I uninstalled some Nvidia packages that should not have been uninstalled.

Is there a way to reset the jetson Orin?
Or is the only option to use Ubuntu 18?

HI was able to flash the jetson orin with Jetpack 5.0.1 DP using Ubuntu 18.04 on the Host system.

But still, there is no display.

I would appreciate your help. How should I proceed?

Thank you so much!

Logs: (148.6 KB)

I tried to install Jetpack 5.0.2 to see if the display would work with it. But no luck so far.

I tried to see the log at /dev/ttyACM0 and can see that it says:
Please complete system configuration setup on theg. /dev/ttyACMx where x can 0, 1, 2 etc.

Boot output from UART:
boot_output_5.0.2.txt (60.2 KB)

How can I complete system config using a serial console?
The display still does not work.

SDKM_logs_JetPack_5.0.2_(rev._1) (190.7 KB)


Do you see /dev/ttyACM0 on your host machine if you have the type C flash port connected to your host?

Also, is your monitor a pure DP? Or you are using some converter here?

Yes, I saw the port /dev/ttyACM0 on the host machine.
When I do “sudo cat /dev/ttyACM0”, I can see all of the logs printed in the terminal.

I have tried both with DP to DP and with DP to HDMI.
Yes, I have both a pure DP and a pure HDMI port.

How can I setup the jetson through dev/ttyACM0?

Could you please help me with it. I really appreciate your support. Thank you


You need to use console tool. Cannot use cat to dump log.

sudo picocom -b 115200 /dev/ttyACM0.

If there is no picocom on your host, then just install it…


Thanks for the advice.
With your command, I was able to setup the jetpack 5.0.1 DP via the serial console. Just like here:

Log: (107.9 KB)

But still, the display only worked for once. When I rebooted it, the display does not work.
Maybe it disabled OEM as mentioned here:

I cannot ssh into it either.

I would appreciate any help. Thanks.


There is a known bug in 5.0.2 and that cause type C fails to work. Need to apply the patch here.


Aftr flashing Jetpack 5.0.1, there is no display and I cannot ssh into it.


sudo picocom -b 115200 /dev/ttyACM0
[sudo] password for kulbir: 
picocom v2.2

port is        : /dev/ttyACM0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,

FATAL: cannot open /dev/ttyACM0: No such file or directory

Even the following command fails:
sudo ./ jetson-agx-orin-devkit mmcblk0p1

with the same error as before “Reading board information failed”.

Should I install Jetpack 5.0.1 DP again and setup using serial console?

Also, how can I know the IP address and name if the display, ssh or the ttyACM0 don’t work?

I flashed Jetpack 5.0.2 with the patch that you shared.

But still there is no display available.
Log from picocom during boot:
boot_log_5.0.2._after_patch.txt (90.7 KB)

SDKM log:
Patch_applied_noscreen_SDKM_logs_JetPack_5.0.2_(rev._1) (140.4 KB)

I cannot use picocom to set it up using the terminal either. There is no option. It says:
Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

It mounts a partition called “L4T-README” though. Not sure if that helps.

The link to setting up OEM config in the following page is broken: Jetson AGX Orin Developer Kit User Guide - Two Ways to Set Up Software | NVIDIA Developer

Could you please help me to set it up using the terminal?
or use the OEM config?

Thank you.


Just want to clarify… this /dev/ttyACM0 node is on your x86 host. Not your jetson.

After you plug the type C usb to your host. If your “L4T-readme” is coming out, then there shall be /dev/ttyACM0 on your host side too…

The /dev/ttyACM0 will give you the OEM config window…

I installed Jetpack 5.0.1 DP again.

This time, I did “Manual setup for Jetson Orin 32GB” with Pre config and only installed the L4T BSP only without SDK components.

Was able to use the terminal console to access the jetson via terminal using:
sudo picocom -b 115200 /dev/ttyACM0
Then I entered the username and password that I entered in the SDK manager.

But I still do not have a display.

The terminal console never worked with 5.0.2 even after flashing with the patch.

How can I have the display and ensure that it will boot up normally?

Looking forward to your suggestions.


Just to clarify few things here.

  1. I don’t have any “patch” to fix your display issue. None of my patch or comment here is for your display.
    That sounds a unknown issue to me. And I think we could check that after we fix your console issue.

  2. If you are talking about /dev/ttyACM0 never showed up on your host when you flash with sdkamanger jp5.0.2, then please describe the detail steps how you apply the patch and flash your board…

  1. Yes, I understand.

  2. I am able to see the output at /dev/ttyACM0 when I flash 5.0.2. But then it says Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

For flashing 5.0.2, I dd:
“Manual setup for Jetson Orin 32GB” with Runtime setup and only installed the L4T BSP only without SDK components.

My current situation:

I have Jetpack 5.0.1 DP. I have access to the serial console.

Ubuntu 20.04.4 LTS ubuntu ttyTCU0

ubuntu login: companion
Welcome to Ubuntu 20.04.4 LTS (GNU/Linux 5.10.65-tegra aarch64)

 * Documentation:
 * Management:
 * Support:

This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

To restore this content, you can run the 'unminimize' command.

304 updates can be applied immediately.
223 of these updates are standard security updates.
To see these additional updates run: apt list --upgradable

Last login: Thu Oct 27 22:24:17 CDT 2022 from on pts/0

Log of installing SDK components: (327.9 KB)

Log of installing 5.0.1: (95.6 KB)

I am able to reboot and then still have access to /dev/ttyACM0.

Should I disconnect the microUSB debug cable now and try to boot it?
or should I update/install any packages or see any IP addresses before I shut it down and lose access to /dev/ttyACM0?
(I am asking because earlier, once I shut it down, it never came back again)

Thank you