Cannot flash JetsonNano with SDK manager

Hi,

When I try to flash the jetson nano through SDK manager flashing error of every blocks appear in terminal tabs:

...
09:54:07 INFO : Flash Jetson Nano : [ 1.2943 ]
09:54:07 ERROR : Flash Jetson Nano : Board ID(3448) version(200)
09:54:07 INFO : Flash Jetson Nano : copying bctfile(/home/user/nvidia/nvidia_sdk/JetPack_4.2.1_Linux_GA_P3448/Linux_for_Tegra/bootloader/t210ref/BCT/P3448_A00_4GB_Micron_4GB_lpddr4_204Mhz_P987.cfg)... done.
...
10:01:26 ERROR : Flash Jetson Nano :
10:01:26 INFO : Flash Jetson Nano : ---- Raw to Sparse Image Converter v1.0 ----------------------------
10:01:26 ERROR : Flash Jetson Nano : 0: RAW: 5242880( 5 blks) ==> 28:5242892
10:01:26 ERROR : Flash Jetson Nano : 1: SKP: 32505856( 31 blks) ==> 5242920:12
10:01:26 ERROR : Flash Jetson Nano : 2: RAW: 1048576( 1 blks) ==> 5242932:1048588
...
10:03:19 ERROR : Flash Jetson Nano : -- Total: ---------------------------------------------------
10:03:19 INFO : Flash Jetson Nano : 144 CHUNK 15032385536( 14336 blks) ==> 4385146588(4182 blks)

PS: I use manual install because I can’t login

Can you help me fix this issue
Thanks

Hi mrtom31,

Please ignore this error message in sdkmanager Terminal tab.
(We are checking this issue internal, sorry for confusing you]

You can keep using sdkmanager to flash os and SDK components, the error log doesn’t effect the result.
You also can use Etcher tool to flash image on SD card:
https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#write

Hi carolyuu,
Unfortunately I tried every method from the your link (etcher or command line flash) and it didn’t work neither. I posted in another topic (under thomas.pegot social account) and a moderator told me to do this method instead.

Also after I flashed I have the same issue I have no output from screen, I can’t connect in ssh, in serial.

Here is the related topic: https://devtalk.nvidia.com/default/topic/1058312/jetson-nano/nano-doesn-t-work-after-flashing-jetpack-4-2-1-under-windows/post/5367035/#5367035

Hi mrtom31,

Are you flash successful?
If yes, can you see the NVIDIA logo? or there are no hdmi output?

I suggest you can check your power supply. we’re using 5V power supply.

yes except that I skip SDK component since I can’t login with my current login it also said I can’t connect to ssh (to the jetson nano).

There are no output to the hdmi and it doesnt appear to the network when I connect the ethernet port.

At the moment use Power Jack input with J48 pin connected.

Hi mrtom31,

At the first boot up, are you completed the initial setup process? (setup username, password…)
You must completed this part, then you can login to ssh.

Ok unfortunately the screen stay black sayin “no output”

I tried again:

  • format
  • flash
  • no output from hdmi
  • tried TTL to USB serial communication and no answer neither.

Is this because I have the model P3450 and not P3448 mentioned on sdk manager?

Hi mrtom31,

It’s no issue for model name P3450.
Please try again with your #8 steps:

  1. Format: please format to ext4
  2. Flash: Please using sdkmanager to flash or flash by manually:
$ cd /home/<yourname>/nvidia/nvidia_sdk/JetPack-4.2.1_Linux_GA_P3448/Linux_for_Tegra
$ sudo ./flash jetson-nano-qspi-sd mmcblk0p1
  1. No output from hdmi: If still no output, please try change others display.
    (At the point, please check your LED still keep light)

Hi carolyuu,

I used flash by manually after formating to ext4.
It said:

*** The target t210ref has been flashed successfully. ***
Reset the board to boot from internal eMMC.

So I just reinsert power and nothing in screen. I tried communication over serial and then no answer.

Since it said reset the board I tried next to use Buttons RST (system reset) and same no answer.

Unfortunately I don’t have any other screen. Also serial communication should work anytime? I used to do my first boot on it with my orange pi (no hdmi port).

It might be due to my screen which is not recognized by my nano. Even though previous last month I flashed Ubuntu and worked fine but I believe it wasn’t a jetpack.

But I don’t get it why I can’t communicate with TTL to USB.

I finally found why I couldnt use serial console (jumper of CH340 put in wrong place).

Now I can see terminal at first boot and it stucks at:

Starting kernel ...

<hit enter to activate fiq debugger>
[    1.028262] tegradc tegradc.1: dpd enable lookup fail:-19
[    1.539758] Host read timeout at address 545c00c4
[    1.755610] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.763168] imx219 6-0010: board setup failed
[    2.437011] cgroup: cgroup2: unknown option "nsdelegate"
[    3.777111] using random self ethernet address
[    3.781666] using random host ethernet address
[    3.819078] using random self ethernet address
[    3.823545] using random host ethernet address
[    3.905625] random: crng init done
[    3.909032] random: 7 urandom warning(s) missed due to ratelimiting
[   11.688267] Please complete system configuration setup on /dev/ttyGS0 to proceed...

Hi mrtom31,

The issue fix?
The log show, you need complete the setup process. (setup the username, password and location…)
Please connect HDMI monitor to complete the first setup. Thanks!