Failed to flash Jetson nano using flash.sh script

Hi
I Tried to flash Jetson nano .But failed.It is showing the below error.

[ 7.4035 ] Flashing the device
[ 7.4064 ] tegradevflash --pt flash.xml.bin --storageinfo storage_info.bin --create
[ 7.4092 ] Cboot version 00.01.0000
[ 7.4118 ] Writing partition GPT with gpt.bin
[ 7.4124 ] […] 100%
[ 7.4161 ] 00000007: Written less bytes than expected
[ 26.2382 ]
Error: Return value 7
Command tegradevflash --pt flash.xml.bin --storageinfo storage_info.bin --create
Failed flashing t210ref.
Kindly help me in resolving this error.
Thanks in advance

What is your command to do the flash?

sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1

Please follow this page and share us the full log on both side.

https://elinux.org/Jetson/General_debug

Are you using nvidia devkit or custom carrier board?

Ok.Thanks. I will check.I am using nvidia devkit.

Hi
I am attaching error log along with this.
Kindly find the attachment.uart_log.txt (7.1 KB)

Hi joseneethu75,

Is using sdcard image able to make this module work?

Yes

Is this Linux_for_tegra package downloaded by sdkmanager or you manually download it from other link?

manually downloaded

Please remove it and use sdkmanager to download this folder and try again.

ok.I will check

Hi
I flash Jetson nano development kit failed as well.
I did it in following steps:

  1. Install SDKManager on a fresh installed host machine with Ubuntu 18.04.
  2. Insert a bootable SD card into Jetson anno and boot up
  3. Run SDKM from host and select JetPack 4.3
  4. Install all the components to host and target. Flash the target has been checked. Therefore, the target has been flashed from SDKM with SDKM created image.
  5. The SDKM flashed SD card has limited storage side to 16GB. Therefore, I am using the flash command to flash the SD card again.
  1. set Jetson nano board in force recovery mode by: connect Pins 9 and 10 in J50 by using the connector on J48.
  2. connect MircUSB to host
  3. My command is: sudo ./flash.sh -S 59GiB jetson-nano-qspi-sd mmcblk0p1

The flash failed at error code 3. Please refer to the flash-failure.txt for details
flash-failure.txt (28.1 KB)

After flashed successfully, unplug the MicroUSB connection to host, Put the jumper from J50 to J48. Plug in the power on Power Jack.
Device boots up properly, but can’t install components by using SDKManager as SDKM can’t identify it is connected.

Hi,

Just want to make it easier to understand… Have you successfully flash the board or not?

Please do give a clear description for it.

The flash failed at error code 3. Please refer to the flash-failure.txt for details

That sounds you have error during flash.

After flashed successfully, unplug the MicroUSB connection to host

Flash somehow works now. What’s going on?

Hi
Sorry my statement is not clear.
The first flash command failed with error code 3.
Re-run the flash command command success. The target has been flashed with the image created by SDKM and storage size is as I expected.
Device boots up properly, but the SDK Manager can’t identify it has connected.
From Jetson nano, I also can’t see the connected flag on the top right corner of the screen.

Have you configured the user account/pwd after flash?

Do you mean the log in to Jetson Nano user name and password? if Yes, I did.

Previous post in this box has been deleted as it was invalid after investigation.

Re-flash the SD card with the same command, it successfully flashed and trigger the Jetson nano first time boots up.
Now the SDK Manager has detected the Jetson Nano being connected.
It seems that the system (flash software, interface to Jetson Nano, and software installed on Jetson Nano) is not working reliably.

After success in above (flash, boot up, connect Jetson Nano with SDK Manager), install the components on Jetson Nano failed.
Refer to the log file for details
SDKM_logs_JetPack_4.3_Linux_for_Jetson_Nano_[developer_kit_version]_2020-09-01_14-22-42.zip (180.4 KB)

I checked the Jetson Nano, it seems that the image generated by flash command has something wrong which may result the install components failure? Please refer to the photos taken from the Jetson Nano screen:

The software updater shows lots of installation needs to be updated (refer to photos):




I tried to update them, but failed as below:

What can I do for it?
Thanks

Hi changwen.xie,

The picture you posted here is normal behavior because the installation is broken.

Please try to use latest sdkmanager (jetpack4.4).

Device boots up properly, but the SDK Manager can’t identify it has connected.

Are you able to ping the device after device is up?
Actually, it is just through internet or virtual usb-internet interface. Not a special trick. You can install components even from the other side of the earth once you have a valid IP.