Cannot get materials to blender

I have problems bringing in usd scenes with materials.
See my video:

I get only geometry, no materials at all. What can I do?
I also tried this method ( USD Preview surface ) but no good for me:

In the Omniverse Create click on the “Save with options” instead, there you will be able to include Preview Surface into your USD file.

Thanks for you help!
Sorry, I cannot see that Preview Surface option…

please see my video:

My bad, indeed there’s no such option there, It looks like it can’t be done from the Omniverse Create. In the post you mentioned, I used Unreal Engine to generate a preview surface, it might work in your case too. Just open your USD scene in UE5, and export it right away as USD, there should be plenty of options.

That is a familiar option window, I try!!
Only bad thing is that my custom lights are lost, but maybe I can export them from Create…

Hi @pekka.varis. Please note that only OmniPBR and OmniGlass MDL materials are supported in Blender USD IO. As @vkarshtein suggested, generating USD Preview Surface materials for those USDs should give better results.

@makowalski if OmniPBR and OmniGlass MDL materials are supported in Blender then why do I get only gray geometry if the video at the first post in this topic above?

That asphalt material is OmnipPBR, I believe…

@pekka.varis Thanks for the reply. Would you be able to share the USD and textures with me so I can debug, if possible? Please feel free to direct-message me to share the files, if you prefer. Thanks.

1 Like

@vkarshtein good news!
I used the UE5 Omniverse export with these settings:

just a few minor errors:

Then I downloaded this from my localhost folder with Nucleus, unzipped it and tried to import the scene with
Blender´s Omniverse Import USD feature these settings:

After few minutes of waiting, the USD Preview materials came in! Thank you so much.