OmniPBR textures missing after exported USD

Materials are missing after I export the USD file from Omniverse. So basically, I added an OmniPBR shader to a cube, assigned a png texture to Albedo map, and saved the USD file. Then I opened the USD in Maya and another software. The cube had fell back to the default shader in Maya instead of the original USD shader. Am I missing a step here? I also noticed there are no mdl files saved next to the USD file

Something I want you to try as a better workflow. Rather than just save the usd in Create, I would like you to “collect it”. This will save all of your texture files and mdl to one local folder location. This will make it much easier to find all the resources you need to open in Maya or Max etc. I just tried this with 3dsmax and it worked.

When you just save the usd, it will leave the resources like the png texture in place on the local hard drive. It will not write out the mdl shader to a file either. When you “collect” the scene, it will package up the resources along with the usd file.

Thanks for your quick response. I tried the Collect tool but material is missing. Here is Maya log:

"file -f -new;
// Result: untitled
file -import -type “USD Import” -ignoreVersion -ra true -mergeNamespacesOnClash false -namespace “new_file” -options “;shadingMode=[[useRegistry,rendermanForMaya],[useRegistry,MaterialX],[pxrRis,none],[vray,none],[useRegistry,UsdPreviewSurface],[displayColor,none],[none,none]];preferredMaterial=none;primPath=/;readAnimData=0;useCustomFrameRange=0;startTime=0;endTime=0;importUSDZTextures=0” -pr -importFrameRate true -importTimeRange “override” “C:/Users/vrsuser02/Pictures/USD test/new_file.usd”;
// File read in 0.047 seconds.
// Warning: file: C:/Program Files/Autodesk/Maya2023/scripts/others/supportRenderers.mel line 67: The renderer “arnold” used by this scene, is not currently available. The “mayaSoftware” renderer will be used instead. To prevent this message from being displayed in the future, set the environment variable: MAYA_NO_WARNING_FOR_MISSING_DEFAULT_RENDERER=1

Also, when you are opening the usd file please do not use the standard built in maya import method. Use the official ov connector open file. This works much better that the build it and it should work directly.