Cannot Jetson Orin boot from M.2 SSD. ERROR: Error initializing runtime service trusty_fast


I want to use the NVMe M.2 SSD that contains Jetson L4T with another Jetson Orin. but I get the following error message and cannot start it. if you have a configuration for booting.
Could you please share it with me?

Error Logs:
Synchronous Exception at 0x0000000876C36380
ASSERT [ArmCpuDxe] /dvs/git/dirty/git-master_linux/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/ArmPkg/Library/DefaultExceptionHandlerLib/AArch64/DefaultExceptionHandler.c(273): ((BOOLEAN)(0==1))

ERROR: Error initializing runtime service trusty_fast
minicom.cap (40.2 KB)

Hi user88043,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in NVMe SSD?

It is the assertion in UEFI which cause boot failed.

Jetson UEFI firmware (version v1.1.2-0165e807 built on 2022-03-15T00:54:10-07:00)

It seems an old release.

Hi KevinFFF.

Thank you for reply.

I’m using Jetson AGX Orin devkit.
And NVMe SSD contains JetPack 5.0.2.

Could you help to verify with latest JP5.1.1(R35.3.1)?

It seems the known issue and has been fixed in the current release.

Thank you for your useful information.
I will try to update JP5.1.1 in NVMe.

1 Like

I tried update JetPack5.1.1.
I was able to boot on the ORIN that used for updated.
However, I put the SSD in another ORIN and tried booting, but I still got the same error.
Do all ORINs need a JetPack update to boot from SSD?

NVMe SSD only contains rootfs.
There’re other partitions like bootloader stored in internal eMMC.

You should use the following command to flash them into internal eMMC before inserting the NVMe SSD.

sudo ./ jetson-agx-orin-devkit mmcblk0p1
1 Like

Thank you for the solution.
I booted ORIN from NVMe SSD.
If there is a way to update just the bootloader or UEFI firmware please let me know.

You could use the following command to update UEFI only for AGX Orin.

sudo ./ -r -k A_cpu-bootloader jetson-agx-orin-devkit mmcblk0p1

Thank you for letting me know.

Unfortunately, It was not possible to boot from NVMe SSD only with the above method.

Thank you for your great support.
I knew you would follow through with helping me. Thank you so much!

That command is used for updating UEFI only.
You could refer to Linux_for_Tegra/bootloader/t186ref/cfg/flash_t234_qspi.xml for other partitions.
I would suggest flashing the AGX Orin once before using it with NVMe.

1 Like

Thank you for your kind attention.
As you suggested, I would like to flash once and then boot with the NVMe SSD.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.