Cannot Run ROS2 navigation example


I have been trying to run the nav2 carter example for isaac for about a week now and it simply does not work. I don’t know the exact cause of the problem, but I do know that rviz launched by the nav2 bringup refuses to pull map information from isaac.

I’m running ROS2 Humble on Ubuntu 22.04. I should also specify that the only ROS extension I have enabled on Isaac is the ROS2 Humble extension.

I have changed nothing from the code in the example, nor have I touched the action graphs in the sim.

After running the instructed launch command, the map does not appear in rviz and I get the following error in the GUI:

The terminal continually spits out the following error:

[component_container_isolated-2] [INFO] [1678988560.156103150] [global_costmap.global_costmap]: Timed out waiting for transform from base_link to map to become available, tf error: Invalid frame ID "map" passed to canTransform argument target_frame - frame does not exist

The rqt_graph for the system as a whole looks like this:

Run ros2 doctor also gives me no info as all checks pass.

The navigation does not work and attempting to use it does nothing. My guess is nav2 is not receiving any map information from the simulation in Isaac, but I have no idea how to fix this.

I should also note that I have tried a to send map data directly by using the map_server service:

ros2 service call /map_server/load_map nav2_msgs/srv/LoadMap “{map_url: carter_warehouse_navigation.yaml}”

But this does nothing and Rviz still does not receive any map information or show the map specified (I used the relative path to the yaml file and the service was, in fact, able to find it).

Any help is appreciated.

Hi @juan17 - Have you tried the example with latest Isaac Sim 2022.2.1 release?

Let us know if you still see the issue with it.

@rthaker Yes! The example works now!

I updated Isaac to 2022.2.1 and ran the example again with the new ros2-workspace repo and the single carter navigation example works now!

Thank you so much!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.