Can't backup jetson-agx-orin-devkit 32g

Hi, I need to back up my whole system and packages installed on Jetson agx orin devkit with jetpack 5.1 R35.2.1, so I tried the way on this (Flashing Support — Jetson Linux<br/>Developer Guide 34.1 documentation) link. I followed the instructions in backup_restore/README_backup_restore.txt, and no error occurred. Then when i run the command >> sudo ./tools/backup_restore/ -b jetson-agx-orin-devkit i face the error below:

sed: can’t read /home/david/Jetson_Linux_R35.2.1_aarch64/Linux_for_Tegra/bootloader/ramdisk_tmp//etc/ssh/sshd_config: No such file or directory
command is failed
Cleaning up…

I tried this way on host 20.04 and 18.04, and the same error occurred. I even tried to clone the system image with >> sudo ./ -r -k APP -G clone.img jetson-agx-orin-devkit mmcblk0p1
and another error occurred:

Skip generating system.img
Not signing of kernel-dtb
Existing tbcfile(/home/david/Jetson_Linux_R35.2.1_aarch64/Linux_for_Tegra/bootloader/uefi_jetson.bin) reused.
Skip generating EFI system partition image.
EFI system partition image (esp.img) not found.

any solution to backup jetson?

Sorry for the late response, please refer to Flashing Support — Jetson Linux Developer Guide documentation (

Thanks for your reply. but the problem still insists. we are unable to locate the system.img image file mentioned in the first step which is found in the link above in the section about cloning. when I run the following command:$ sudo ./ -r -k APP -G backup.img jetson-agx-orin-devkit mmcblk0p1
i get the outputs found in the attached log file.
log.txt (17.6 KB)
Any suggestions how to solve that?

Hi davidbdavit,

Are you using the devkit or custom board for AGX Orin?

EFI system partition image (esp.img) not found.

Your backup command is stopped due to this message.

Can your board boot up and log-in to the desktop successfully?

Hi, Thanks for your reply.
I’m definitely using a devkit board for AGX Orin and my board boots up and logs in to the desktop normally without any problems (before and after running mentioned command). As I noted in my last reply I was unable to locate system.img file mentioned in this link.
could it be that the problem is related to me not finding and copying the said file?

How did you flash the board (with SDKM or flash script)?

Do you mean “Linux_for_Tegra/bootloader/system.img” not exist?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.