Can't bring normal WiFi up after setting up hostapd in TX2

Yesterday I successfully set up hostapd/dnsmasq by following this tutorial: I might have had a few side steps, I’m not completely sure.

I could bring wifi back up by commenting out the non lo-related lines in /etc/network/interfaces, and running sudo service networking restart. Again, it was yesterday, there might have been some additional steps which I forgot about

Today I’m trying that again, but a normal wifi connection can’t seem to be establishable. I used i3wm to test these things, and today someone opened a gnome session on the machine, which might have automatically messed with some config files, but the issue might not be related at all.

Here is some relevant info:

# uname -a
Linux tegra-ubuntu 4.4.38-tegra #1 SMP PREEMPT Thu May 17 00:15:19 PDT 2018 aarch64 aarch64 aarch64 GNU/Linux

It is a Jetson TX2, connected with the devkit, plugged into ethernet

I took dmesg outputs both when booting with the hostapd-compatible /etc/network/interfaces, and without. When without, these lines popped up:

CFG80211-ERROR) __wl_cfg80211_scan : Invalid Scan Command at SoftAP mode
CFG80211-ERROR) wl_cfg80211_scan : scan error (-22)


ps aux | grep hostapd

shows no processes running (except the grep process)

# iw wlan0 info
Interface wlan0
    ifindex 5
    wdev 0x1
    addr 00:04:4b:c4:f3:04
    type managed
    wiphy 0

This is what I think it should normally look like, if not connected, so that’s fine. When using hostapd, it comes up with an ssid and a type AP

But then this comes:

# ip link show wlan0
5: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT mode DORMANT group default qlen 1000
    link/ether 00:04:4b:c4:f3:04 brd ff:ff:ff:ff:ff:ff

Normally, it should be state UP mode DORMANT, but not here. When with hostapd, it’s state UP mode DEFAULT

Then there’s this, which I think is normal across tegras, as it’s the same in the other tegras I could play with, even when they are connected to wifi

# iwconfig wlan0
wlan0     no wireless extensions.

I don’t know how normal this is, but lspci outputs nothing. However, here’s lshw:

# lshw -class network
       description: Ethernet interface
       physical id: 3
       logical name: usb0
       serial: 72:0a:17:35:8a:ea
       capabilities: ethernet physical
       configuration: broadcast=yes driver=g_ether driverversion=29-May-2008 firmware=tegra-xudc link=no multicast=yes
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 4
       logical name: dummy0
       serial: 9a:21:99:f6:2b:6b
       capabilities: ethernet physical
       configuration: broadcast=yes driver=dummy driverversion=1.0
       description: Ethernet interface
       physical id: 5
       logical name: wlan0
       serial: 00:04:4b:c4:f3:04
       capabilities: ethernet physical
       configuration: broadcast=yes driver=wl driverversion=0 multicast=yes
       description: Ethernet interface
       physical id: 6
       logical name: eth0
       serial: 00:04:4b:c4:f3:06
       size: 1Gbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=eqos duplex=full ip= link=yes multicast=yes port=MII speed=1Gbit/s

Running scan through wpa_cli:

# rfkill list
0: bluedroid_pm: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmfmac-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no

What else should I try?


you can try “lsmod”

# lsmod
Module                  Size  Used by
uvcvideo               86603  0
videobuf2_vmalloc       6454  1 uvcvideo
<b>bcmdhd</b>               7640843  0
spidev                 10966  0
pci_tegra              75659  0
bluedroid_pm           13564  0

i have too same problem.
But we can see this post :

I found a discussion about the compatibility of the module bcmdhd and WEXT :

The TX2 has a wifi that works without iwconfig.
So, i didn’t try to rebuilt with this methode.