Can't get profiler to work on Nexus 7

I can’t get the profiler to work on a Nexus 7.

It’s running 4.2.2, JDQ39, and it’s been rooted.

I had to make some changes to the .CMD files to get everything deployed properly (to /data/data/com.nvidia.tegraprofiler). But when I run quadd_d, the “.log” file shows this error:

[Thu Oct 10 12:22:31 2013] Tegra profiler (uid: 0)
[Thu Oct 10 12:22:31 2013] branch: Blackrock2, version: 1.39, build date: Aug 28 2013 at 13:06:46, build id: 1.2.16744070,151
[Thu Oct 10 12:22:31 2013] samples version: 16
[Thu Oct 10 12:22:31 2013] io version: 5
[Thu Oct 10 12:22:31 2013] load_quadd_modules (jni/…/Target/quadd_d/quadd_d/jni/qm.c:701): Error: can’t find module: kprobes_module.ko
[Thu Oct 10 12:22:31 2013] quadd_module_init (jni/…/Target/quadd_d/quadd_d/jni/qm.c:790): Error: load_quadd_modules
[Thu Oct 10 12:22:31 2013] main (jni/…/Target/quadd_d/quadd_d/jni/main.cpp:432): quadd_module_init error

The two “.ko” files are in the /data/data/com.nvidia.tegraprofiler/TegraProfiler/3.1.10-g05b777c, and I also tried copying them to the same directory as quadd_d, but got the same error. I’ve rooted this device, and am doing all this after a “su.”

What am I doing wrong?

I’m sorry you’e encountered this issue. I’ll be in touch directly to help sort this out. Thanks for the problem report.