Can't run the launcher, it can't download the GDPR and EULA

I’d like to install the launcher to be able to better understand omniverse, I am especially interested in looking at the code of the apps and extensions. But when I download and launch the explorer, I keep getting this message:

Unable to download GDPR agreements and EULA. You may need to inspect your internet connection and restart the launcher. Try these troubleshooting links for Proxy and Firewall configurations.

The first link goes to a more general page. The second link goes to a firewall page. Is there a way for me to better debug the problem:

Do I need some auth token to try this out … not sure how to proceed.

Hello @user113598! Welcome to the Community!

Try adding your server to the allowed list: Firewalls — Omniverse Launcher documentation

Also if your logs show an error about self-signed certificates in their chain:
FetchError: request to failed, reason: self signed certificate in certificate chain
Which might mean that you have an 802.11x “transparent” proxy redirect. Your may want to see if they are redirecting your DNS until you authenticate it.

Can you please explain in more detail. Can you throw me a link to an article that shows how to do this?

All I understand is that this “https://*” I need to add to some firewall whitelist. But how?

Hi @WendyGram and @Dabilin Thanks for your responses.

I was able to get over this hurdle this weekend. I think its a proxy issue from our company network. I was able to get this installed if I got off the company network.

Thanks Wendy for the suggestions. And Dabilin this also makes sense as well. I’m not sure they will want to update firewall rules so in the short term I think I’ll have to deal with not being on the network when I install.

Bottom line, how do you fix it? Reinstall without internet?

I took myself off our company VPN. Then I was able to install it. After that it worked fine


What do you mean? Your company’s VPN? I work from a personal computer, no VPN, with an Ethernet connection

I have nothing to disconnect from.

Yes @Dabilin , I am usually logged into my company’s VPN. I’m thinking from @WendyGram post above, its probably a firewall issue. So, what I did was to disconnect from my company VPN and then I was able to get everything installed. So I was still on the internet but not on my company’s network.

So in your case, since you are not on a VPN or company network, I’m not sure why you can’t install.

I have similar error:

Unable to download GDPR agreements and EULA. You may need to inspect your internet connection and restart the launcher. Try these troubleshooting links for [Proxy]( and [Firewall]( configurations.

How can I solve it ? How add it server to the allowed list in firewall ? And I don’t have firewall, why I have got this error ?

Good afternoon, I had a similar error - it is not even possible to log in or download the product. The documentation does not specify exactly where to solve this problem. When adding to Firewall exception - it asks for ip-addresses. Can you provide them? Because https://* cannot be added. Because of this I can’t start using your product. Not connected to VPN, additionally firewall is on and off. I will wait for your reply, thanks!



The request could not be satisfied.

Request blocked. We can’t connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner.
If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.

Generated by cloudfront (CloudFront) Request ID: GcFZPpDOg0pxt6_GGTjHkWYPzrWv8oHcg-_r2iAPZ2gPlI7kzWTeMQ==

Tried to download again from Omniverse website(also tried to do Cleaning Tool to reinstall the program) - alas, no download from different PCs and regions. So the problem is on the Nvidia server side - can you confirm this so I don’t have to look for a solution if it’s up to you?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.