Centos 7 driver installation issue

Our Centos 7.4 workstation can’t start GUI. I tried to install Nvidia driver to replace previous Nouveau driver. I followed instructions in pre-installation (session 2), installation (session 3) and post-installation (session 13) on the official page. Most commands look successful. However, the workstation still can’t start GUI and some check commands failed. For example:

$ cat /proc/driver/nvidia/version
cat: /proc/driver/nvidia/version: No such file or directory

$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Is there anything else I could do? I attached nvidia-bug-report.sh report. Does it looks like hardware issue? Feel free to let me know if further info needed. Thanks.
nvidia-bug-report.log.gz (138.0 KB)

You have a Kepler based GT730 so you need to install the 470 legacy driver. The 545 driver doesn’t support your gpu.

Thanks @generix for your suggestion. I tried to install Nvidia legacy 470 driver. Luckily GUI came back. I can now see the login graphical interface.

However, when I tried to login, the desktop did not appear, and instead, some text was displayed before returning to the login screen. See the video. The photo of the text shown is attached.

I tried “mv ~/.config ~/.config_backup” which didn’t work.

Command “sestatus” output:
SELinux status: disabled

I also attached current nvidia-bug-report.sh report and latest part of /var/log/messages.

Note that error occurred when creating the report as shown below. Thanks.

Running nvidia-bug-report.sh…/bin/nvidia-bug-report.sh: line 1141: 193938 Segmentation fault (core dumped) $vulkaninfo 2> /dev/null
complete.

Line 1141 and above few lines of nvidia-bug-report.sh are:

1133 fi
1134 ) | $GZIP_CMD >> $LOG_FILENAME
1135
1136 else
1137 (
1138 echo “Skipping nvidia-smi, nvidia-debugdump, and vulkaninfo due to --safe-mode argument.”
1139 echo “”
1140 ) | $GZIP_CMD >> $LOG_FILENAME
1141 fi

nvidia-bug-report.log.gz (1.1 MB)
var.log.messages.txt (196.0 KB)

Please post the output of
ls -l /dev/nvid* /dev/dri/*

It outputs:

$ ls -l /dev/nvid* /dev/dri/*
crw-rw----+ 1 root video 226, 0 Jan 17 16:22 /dev/dri/card0
crw-rw----+ 1 root video 226, 128 Jan 17 16:22 /dev/dri/renderD128
crw-rw-rw- 1 root root 195, 0 Jan 17 16:22 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Jan 17 16:22 /dev/nvidiactl
crw-rw-rw- 1 root root 195, 254 Jan 17 16:22 /dev/nvidia-modeset
crw-rw-rw- 1 root root 235, 0 Jan 17 16:22 /dev/nvidia-uvm
crw-rw-rw- 1 root root 235, 1 Jan 17 16:22 /dev/nvidia-uvm-tools

/dev/nvidia-caps:
total 0
cr-------- 1 root root 238, 1 Jan 17 16:49 nvidia-cap1
cr–r–r-- 1 root root 238, 2 Jan 17 16:49 nvidia-cap2

Please check if the user to log in is added to the “video” group.

$ id -nG “ztron”
ztron docker
$ groups ztron
ztron : ztron docker

Looks user ztron is not in video group. Should I add it to the group?

yes, please check.

For a desktop user, “ztron” probably needs to be in more groups, like audio, usb, plugdev etc. Looks like a restricted docker user.