Changed Desktop Environment

I was installing PyQt5 on my Jetson Nano. The latest solution that I followed was here. I also added the following modules from the previous solutions:

sudo apt-get install build-essential autoconf libtool pkg-config python-opengl python-pil python-pyrex python-pyside.qtopengl idle-python2.7 qt4-dev-tools qt4-designer libqtgui4 libqtcore4 libqt4-xml libqt4-test libqt4-script libqt4-network libqt4-dbus python-qt4 python-qt4-gl libgle3 python-dev libssl-dev
sudo apt-get install qtcreator pyqt5-dev-tools
sudo apt-get install python3-pyqt5
sudo apt-get install qttools5-dev-tools

After restarting I get an " Unable to launch “/usr/bin/startlxde”" error.

I tried to follow this thread, but then the desktop environment changed. It was no longer the usual desktop but rather an “old” desktop which I think is not in Ubuntu anymore ( I checked the terminal and it was named LXTerminal; I tried to execute lsbrelease -a but command is not found)

So I found this video on changing GNOME to LXDE.

What I want is to REVERT this change. From LXDE I want to change back to the GNOME environment.

Are you able to select the desktop environment in the login window?

Hi @DaveYYY. I have a different UI compared to the link. My taskbar is below the desktop instead of at the top.

There is no “small bird icon” on this.

I mean login window, not desktop.

Apologies. I checked on the login window and it only display LXDE, LXDE, and OpenBox.

Can you check if you still have GNOME installed on your system?

No, GNOME is no longer installed, weird.

Anyways I just reinstalled ubuntu-desktop again and it works now, thanks!

1 Like


first of all jetson nano dev kit in new os install and by default python
3.6 install but you can change python 3.8 install via pip3 install

and all step flow give my threads
"How to Install PyQt5 Jetson nano

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.