Unable to launch "/usr/bin/startlxde"


when i restart my jetson i got this error, when i hit okay, the jetson restart and hit this error message in my face (again). It loop, i try it about 4 or 5 time, same thing happend. I waited for 30 mins, the error didn’t go away. unplug and plug my sd card didn’t help either. Anyone knows what’s going on and how to fix it? If you do, please tell me ser, i’m begging you.
(god, please tell me my jetson is not broken)
i’m devastated right now

hello giadinhthai12345,

may I know how to reproduce this issue,
for example,
are you using the default JetPack release image via SDKManager, which release version it is?
what’s the steps to report this failure.
thanks

Hello @giadinhthai12345 First of all your Jetson is Safe.
The problem you mentioned caused is due to the desktop Environment.

you can fix the problem by following the procedures below:

  1. click okay in this dialogue box and you should see login screen appearing.

  2. Before logging in change the desktop preference to Openbox (options will be in top right panel) and login back ,you should see NVIDIA logo(white and green) after login.

  3. Right click on the screen and open the terminal.

  4. reinstall the LXDE desktop again using the terminal.
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install lxde
    or sudo apt-get install --reinstall lxsession

  5. After this restart the system and you will see the nvidia logo again if openbox desktop is loaded. Right click and exit the desktop.

  6. choose the LXDE desktop preference (like step 2) and login. you will see the jetson booting normally.

you are good to go.

prefer this LXDE desktop since it can save the RAM memory.

@JerryChang This was dude to few desktop update in linux side I guess, I was able to fix the same error by doing the above procedures. I am not sure about root cause.