CloudXR - 5G connection issues

Hello !

My team and I are working on an augmented reality project thanks to CloudXR and 5G. To do so, we use a Samsung Galaxy Note 20 Ultra 5G, the ARCore Android Client of CloudXR and a server in our lab.

So far, we were in Wifi and the connection between the server and the client worked well : we could stream applications from the server on the smartphone.
Now, we are trying to do it on our own private 5G network but the connection between the server and the device cannot be established anymore and the CloudXR app crashes with the following error :
« CloudXR ARCore Client : Error [19], see logs for detail. Exiting. »
Yet, the server and the client are pinging each other.

For information, our base station, core network and the server are in the same VLAN, whereas the smartphone connected in 5G to the base station is under another subnetwork managed by the core.
In WiFi however, the server and client are both connected to the AP and so are under the same subnet.

You can find attached the scheme of our 5G architecture and the logs collected from the device.
We tried to open a larger range of ports according to the logs, we verified the advanced settings of SteamVR, and also deactivate the firewall but nothing helped.

Any idea how we could solve this ?

Thank you for reading me !

CloudXR Client Log 2021-08-31 09.48.05.txt (1.4 KB)
Streamer Client Log 2021-08-31 09.48.05.txt (151.5 KB)


Did you open this Ports?:
|TCP| 47999 |CloudXR Control|
|UDP| 47999 |CloudXR Control|
|TCP| 48000 |CloudXR Audio|
|UDP| 48000 |CloudXR Audio|
|TCP| 47998 |CloudXR Video|
|UDP| 47998 |CloudXR Video|
|TCP| 48005 |CloudXR Video|
|UDP| 48005 |CloudXR Video|
|TCP| 48002 |CloudXR Microphone|
|UDP| 48002 |CloudXR Microphone|
|TCP| 48010 |CloudXR RTSP|
|UDP| 48010 |CloudXR RTSP|

I don’t really understand your diagram. I mean the firewall should have no influence, as you stay in your private network.


Thanks for your feedback.

About the diagram, you are absolutely right, the physical firewall we are using to protect our private network shouldn’t have any impact.
I am talking about the integrated firewall of the Windows Server OS where CloudXR is installed.

About the ports you mentionned : yes, i manually opened these ports (on the Windows Server then) for the inbound and outbound traffic. I also tried to completely deactivate the firewall but it didn’t change anything.

so the RTSP connection (TCP) works. The other channels are all UDP, and use NAT hole punching, and they are failing (or at least some of them). certainly feels like a firewall issue offhand if NAT punch is failing. Could be something specific to management of the 5G vlan, either inside of the base station, or in the core network if that is allocating virtual channels for base station clients.