(Code 52) error after installing CUDA 9.2

Hardware: HP ZBook 15 G3 https://store.hp.com/us/en/pdp/hp-zbook-15-g3-mobile-workstation-(energy-star)

Integrated: Intel® HD graphics 530
Discrete: NVIDIA® Quadro® M2000M (4 GB dedicated GDDR5)

Software: windows 10

My ultimate goal is to run the cuda version of leela chess zero (lc0) on my laptop. https://github.com/LeelaChessZero/lc0/wiki/Getting-Started

In order to run it, I need to install cuda 9.2 However, when I install cuda 9.2 and then follow the directions on that page, lc0 doesn’t find my NVIDIA graphics card. I have successfully installed lc0 on my other computer, so I know that my installation steps are correct. The error I get is: <error CUDA error: unknown error (…/src/neural/network_cudnn.cu:977)

I believe I have traced back the error to the device status of my NVIDIA Quadro M2000M. When I install cuda 9.2 and go to device manager -> display adapters -> NVIDIA Quadro M2000M -> Properties -> General -> Device Status

“Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)”

Could this be causing my problem? When I uninstall cuda 9.2 this error goes away. Is this a problem with my installation of cuda 9.2?

Thanks!

after you uninstall cuda 9.2, what GPU driver version is indicated?

Just now, I went to Control Panel\Programs"Programs and Features" and I uninstalled all of these:

NVIDIA 3D Vision Controller Driver 390.41
NVIDIA 3D Vision Driver 398.75
NVIDIA CUDA Development 9.2
NVIDIA CUDA Documentation 9.2
NVIDIA CUDA Runtime 9.2
NVIDIA CUDA Samples 9.2
NVIDIA CUDA Visual Studio Integration 9.2
NVIDIA Graphics Driver 398.75
NVIDIA HD Audio Driver 1.3.37.4
NVIDIA Nsight Visual Studio Edition 5.6.0.18099 <— except this one, it wouldn’t uninstall for some reason
NVIDIA nView 149.21
NVIDIA PhysX System Software 9.17.0524
NVIDIA Tools Extension SDK (NVTX) - 64 bit
NVIDIA WMI 2.31.0

Then I restart. After opening NVIDIA Control panel (Start -> type “nvidia control panel”) it says I have Version 373.06 installed.

If I go to device manager -> display adapters -> NVIDIA Quadro M2000M -> Properties -> General -> Device Status

it says “This device is working properly”

lc0 requires version 397.44+

what is the latest driver you can install on your system if you use the driver wizard at:

http://www.nvidia.com/drivers

?

When I fill in my information on my NVIDIA Quadro M2000M, it says the latest version is 392.00…

I guess that makes sense, but I’m pretty bummed. I thought that my graphics card could support lc0

You could try using the driver bundled with the win10 cuda 9.2 installer, and disable driver signature enforcement:

https://winaero.com/blog/disable-driver-signature-enforcement-permanently-in-windows-10/

I don’t know if you want to do that or not. I also don’t know for sure it would fix the initial problem you reported, but it might.

Alternatively, if you go to the driver wizard I already linked, and select the Quadro New Feature driver, you should be directed to this:

https://www.nvidia.com/Download/driverResults.aspx/134628/en-us

I think that may be worth a shot.

Will try all of these suggestions, thanks. However, I’ve also found that lc0 can work on cuda 9.1 or 9.0, and this seems to be close enough in terms of performance to the cuda 9.2 version. thanks for the help!

I met the same problem on my laptop. Turned off “Secure boot mode” in BIOS and the problem was gone. I didn’t run the command to disable driver signature enforcement as suggested by Robert_Crovella.

Hardware: EliteBook 8760w
Software: Windows 10 Version 1903
Premiere Pro Version: 13.1.4
NVIDIA: Quadro 5010M (Running Driver Version: 10.18.13.5330)
Runnning 32 Gb of RAM

I’m having some problems with Premiere, when I open it I get the following notification:

“”"
Adobe Premiere Pro
System Compatibility Report
Video NVIDIA Quadro 5010M v.10.18.13.5330
The current version of your NVIDIA graphics driver may not suitably support CUDA 9.2 and may cause issues for Adobe Premiere Pro. We recommend updating to a newer version for optimal performance and stability. Continuing with an older version of the NVIDIA graphics driver may run in software-only mode and may cause slow playback and other issues that mayappear to be a bug.
For more information: https://helpx.adobe.com/en/premiere-pro/kb/gpu-and-gpu-dr

“”"

When I hit “continue anyway” I am experiencing a lot of lag when editing which I hadn’t experienced on earlier versions of Premiere Pro.

I’ve tried to update to the “Nvidia studio driver 430.86 or later” as recommended by Adobe, but it doesn’t install due to “incompatibility”.

How do I get the driver that Adobe recommends to work?

The Quadro 5010m is an old Fermi GPU. The newest driver versions that will work with that GPU are numbered in the 3xx.xx range. 4xx.xx drivers will not work with that GPU, as support for Fermi in general was dropped some time ago.

You’re stuck with whatever driver version is the latest provided for your GPU at http://www.nvidia.com/drivers

You can try updating to the latest and see if that helps. If it does not, then it seems that the Permiere application has moved forward to the point where 5010m is no longer a good choice of GPU to use with it.