Code crashes after a few frames when running Replicator

Hi,

I am trying to create synthetic data with Replicator. For this I wrote a script to set up the replicator scene, after running the script I run Replicator. The script loads a “main object” which will be annotated and for distraction I load some distractor objects with rep.randomizer.instantiate(rep.utils.get_usd_files(PROPS, recursive=True), size=size, mode=‘scene_instance’)

Replicator runs perfectly if I dont load distractor objects. As soon as I try to generate data with distractor objects Code crashes… Sometimes during the first frame, sometimes after a few. Sometimes even if I just preview a frame.

I have a background in Rendering and not in coding so maybe I oversee something obvious. Would be nice if somebody could help me troubleshooting.

  • Operating system: Windows 11
  • GPU / Driver: NVIDIA GeForce RTX 3060 / 31.0.15.1659
  • Code Version: 2022.1.3

Thanks in advance
Jan

Hi @Sturm_1. Let me check with the dev team on this. Could you share some log files from the crash? Here’s how to find them: How to Report an issue with Omniverse

Hi there,

would it be possible to share the script you are running together with the crash log?

Cheers,
Andrei

Hi guys,

Thanks for your support. Log file is here:
kit_20220920_092111.log (860.0 KB)

If possible I would not like to share the script public, even if it is not rocket science.
BUT: I discovered what seemed to be the cause of the crash.
I used rep.randomizer.instantiate(rep.utils.get_usd_files(PROPS, recursive=True), size=size, mode=‘scene_instance’) for creating my distractor objects. When changing the mode to ‘point_instance’ replicator runs without a problem. I worked with like 10 distractor objects so I assumed scene_instance should not be a problem.

BR
Jan

Hi @Sturm_1,

The log doesn’t appear to have a crash report in it. If you’re able to catch a log with a crash report in it, that would be ideal for debugging on our side. The next version of code may also help address this. Will circle back when its available.