Configure USB flashing port

Hello everybody,

At the start I would like to refer that I am a rookie with Jetson TX2.
I just bought a Jetson Tx2 developer Kit that was already pre-flashed.
The JetPack is 4.3 (L4T 32.3.1)
When I close the Jetson it appears me in the terminal the following message:

[FAILED] [Failed to start Configure USB flashing port for device mode] (see the image)

Later I want to conect an external camera in USB 3 port .Whould be a problem because for now the port is working properly.

Thanks for the consideration. If there is a solution for this error I would be glad to hear from you.

The version of L4T currently flashed may not be the same as the one from which you wanted to install, and the two must match due to dependencies. L4T (“Linux for Tegra”) is just Ubuntu with NVIDIA direct hardware access drivers. You can find this version from “head -n 1 /etc/nv_tegra_release”. JetPack/SDK Manager is a front end for installing L4T and for installing some optional packages, for example, CUDA.

What version of L4T do you have currently? To see which L4T goes with a given JetPack/SDK Manager see (you might need to go there, log in again, then go there a second time):

To see JetPack versions, you can go here:

Note that recovery mode is used only for flash, and not for optional package installs. You can deselect flash from SDK Manager/JetPack, and just install packages if the Jetson is fully booted and the first boot account creation has been completed (install uses ssh, and this requires an account to ssh to).

I highly recommend flashing to L4T R32.3.1 (the latest L4T, via JetPack 4.3) if not already there. Some people will use an older release if they require an older CUDA. Also, some of those older releases try to update all of the out-of-date packages upon first boot and can take a long to finish package updates over the internet prior being able to add extra packages (and this can take hours).

Note that this most recent release is the first release where all of those optional packages are available via the native “apt-get” mechanism. All of the earlier releases mandate using JetPack to add those optional packages (using a fully booted Jetson of the correct release). If you have the most recent R32.3.1:

    $ sudo apt-get update
    $ sudo apt-get install nvidia-jetpack

However, you can still use JetPack to install those extra packages if you wish (just uncheck flash first if you have the correct L4T release installed).

Don’t know if this is related to any of your issues, but I saw you had tried to use “jetsonUtilities”, and it required “sudo” but you did not use “sudo”. I do not use this script, but there are a number of administrator-only commands requiring “sudo”. For example, to run “ls” as root (the administrator): “sudo ls”. Some third party scripts are out of date for the most recent release, so be sure that if you use a script that it is for the L4T release you have installed.

FYI, knowing the network address of your Jetson allows JetPack/SDKM to install extra packages after full boot.