Couldn't interrupt u-boot on TX2i

I’ve been having trouble getting to the u-boot monitor on the TX2i. I attempted the following 2 methods of key-presses (both upon powering the TX2i off/on again, and upon issuing the reboot command to terminal):

  • Connecting a physical keyboard to the USB
  • Connecting a TX2 to serial (J17) and sending bytes via minicom to the TX2i.

Neither of these methods worked. What is more worrying is that I never saw any U-Boot-specific messages when booting up (I am assuming there should be a message that says “press any key to interrupt U-Boot”).

Hi ericnmiller99,

Are you using pure driver package from jetpack? I just tried with my device and u-boot is still being interrupted.

TEGRA186
Model: NVIDIA P2771-0000-500
DRAM:  6.8 GiB
MC:   Tegra SD/MMC: 0, Tegra SD/MMC: 1
In:    serial
Out:   serial
Err:   serial
Net:   eth0: ethernet@2490000
Hit any key to stop autoboot:  0 
Tegra186 (P2771-0000-500) # <INTERRUPT>
Tegra186 (P2771-0000-500) # <INTERRUPT>
Tegra186 (P2771-0000-500) # 
Tegra186 (P2771-0000-500) #

https://photos.app.goo.gl/27FnkLWbYLMoXhas7

Here are a couple videos of the boot process if that helps with anything. Where should the “hit any key to stop autoboot” message occur?

The HDMI port never shows this. The ability to stop requires access via the serial console (which goes to the host PC and the PC runs a serial console program talking to the serial UART console). See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Thanks! I knew I was doing something wrong