Crash NVIDIA JETSON

Hello I am using Jetson AGX Xavier Developer Kit , powered with a 14V battery ,
and I m having weird crashes , when I do something like open the search bar on the desktop , it stops and turns off , I want to know why
This is the log I m having after the crash :

  • Jan 28 17:04:23 tpsh-agx-1 dbus-daemon[7088]: [session uid=1000 pid=7088] Successfully activated service ‘org.freedesktop.Notifications’
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 rfbProcessClientNormalMessage: ignoring unknown encoding type 24
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 rfbProcessClientNormalMessage: ignoring unknown encoding type 15
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 rfbProcessClientNormalMessage: ignoring unknown encoding type 22
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 rfbProcessClientNormalMessage: ignoring unknown encoding type 21
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 rfbProcessClientNormalMessage: ignoring unknown encoding type -314
  • Jan 28 17:04:24 tpsh-agx-1 vino-server[7847]: 28/01/2018 17:04:24 Enabling NewFBSize protocol extension for client 192.168.1.163
  • Jan 28 17:04:30 tpsh-agx-1 unity-panel-ser[8177]: window_menu_model_new: assertion ‘BAMF_IS_APPLICATION(app)’ failed
  • Jan 28 17:04:30 tpsh-agx-1 unity-panel-ser[8177]: track_menus: assertion ‘IS_WINDOW_MENU(menus)’ failed
  • Jan 28 17:04:35 tpsh-agx-1 unity-panel-ser[8177]: menus_destroyed: assertion ‘IS_WINDOW_MENU(wm)’ failed
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Removed slice system-getty.slice.
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopped target Graphical Interface.
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Closed Load/Save RF Kill Switch Status /dev/rfkill Watch.
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopped target RPC Port Mapper.
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Thunderbolt system service…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Daemon for power management…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Session 1 of user tpsh.
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Save/Restore Sound Card State…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping RealtimeKit Scheduling Policy Service…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping GNOME Display Manager…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Accounts Service…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping Disk Manager…
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping User Manager for UID 1000…
  • Jan 28 17:04:35 tpsh-agx-1 bluetoothd[7890]: Terminating
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopped target Sound Card.
  • Jan 28 17:04:35 tpsh-agx-1 bluetoothd[7890]: src/adapter.c:adapter_shutdown()
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopping crash report submission daemon…
  • Jan 28 17:04:35 tpsh-agx-1 bluetoothd[7890]: src/plugin.c:plugin_cleanup() Cleanup plugins
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopped target Timers.
  • Jan 28 17:04:35 tpsh-agx-1 nvphsd[7006]: *** killed by handled signal: shutting down gracefully.
  • Jan 28 17:04:35 tpsh-agx-1 bluetoothd[7890]: profiles/input/suspend-none.c:suspend_exit()
  • Jan 28 17:04:35 tpsh-agx-1 systemd[1]: Stopped Discard unused blocks once a week.

Thanks for help

and I m having weird crashes , when I do something like open the search bar on the desktop , it stops and turns off , I want to know why

1.Does it ever get reboot or it just power down and never reboot again?
2. Will you see device shutdown if you put heavy loading on your device?
3. Your log looks like the system is going through a shutdown but triggered by software. I don’t think it is caused by unstable power. If it is caused by power, then it will just go down without showing such “Stopping” log. Could you also dump the serial console log?

  1. Yes it gets rebooted sometimes, sometimes it’s power down, I have another log file where it did not show “Stopping” logs
  2. Yes, especially on the GPU
  3. This is the case for this log file, but it does not always do that. Sometimes it just crashes without showing any log, it’s showed in this serial console log, the last line before power down is :

> [ 113.949362] FAN rising trip_level:1 cur_temp:56400 trip_temps[2]:63000

and then it jumps to the reboot lines.

Thanks

Hi,

Please directly attach the serial console log here. Somehow the pastebin host is being blocked by my network admin.

Can we have a method or steps that can 100% reproduce this issue? Also, do you have only one xavier? Want to see if we can have similar issue on other Xavier too.

Here,

Log file

[ 60.872412] nvgpu: 17000000.gv11b railgate_enable_store:297 [INFO] railgate is disabled.

[ 66.974208] nvgpu: 17000000.gv11b tpc_pg_mask_store:843 [INFO] no value change, same mask already set

[ 111.709727] FAN rising trip_level:1 cur_temp:54300 trip_temps[2]:63000

[ 112.829533] FAN rising trip_level:1 cur_temp:55900 trip_temps[2]:63000

[ 113.949362] FAN rising trip_level:1 cur_temp:56400 trip_temps[2]:63000

ÿâ

[0000.343] W> RATCHET: MB1 binary ratchet value 4 is too large than ratchet level 2 from HW fuses.

[0000.351] I> MB1 (prd-version: 1.5.1.3-t194-41334769-d2a21c57)

[0000.357] I> Boot-mode: Coldboot

[0000.359] I> Chip revision : A02P

[0000.363] I> Bootrom patch version : 15 (correctly patched)

[0000.368] I> ATE fuse revision : 0x200

[0000.371] I> Ram repair fuse : 0x0

[0000.374] I> Ram Code : 0x2

[0000.377] I> rst_source : 0x0

[0000.380] I> rst_level : 0x0

[0000.383] I> Boot-device: eMMC

[0000.398] I> sdmmc DDR50 mode

[0000.402] I> Active Boot chain : 1

[0000.405] I> Boot-device: eMMC

[0000.409] W> MB1_PLATFORM_CONFIG: device prod data is empty in MB1 BCT.

[0000.417] I> Temperature = 50500

[0000.420] W> Skipping boost for clk: BPMP_CPU_NIC

[0000.424] W> Skipping boost for clk: BPMP_APB

[0000.428] W> Skipping boost for clk: AXI_CBB

[0000.432] W> Skipping boost for clk: AON_CPU_NIC

[0000.436] W> Skipping boost for clk: CAN1

[0000.440] W> Skipping boost for clk: CAN2

[0000.444] I> Boot-device: eMMC

[0000.447] I> Boot-device: eMMC

[0000.457] I> Sdmmc: HS400 mode enabled

[0000.461] I> ECC region[0]: Start:0x0, End:0x0

[0000.465] I> ECC region[1]: Start:0x0, End:0x0

[0000.469] I> ECC region[2]: Start:0x0, End:0x0

[0000.473] I> ECC region[3]: Start:0x0, End:0x0

[0000.478] I> ECC region[4]: Start:0x0, End:0x0

[0000.482] I> Non-ECC region[0]: Start:0x80000000, End:0x100000000

[0000.487] I> Non-ECC region[1]: Start:0x0, End:0x0

[0000.492] I> Non-ECC region[2]: Start:0x0, End:0x0

[0000.496] I> Non-ECC region[3]: Start:0x0, End:0x0

[0000.501] I> Non-ECC region[4]: Start:0x0, End:0x0

[0000.506] E> FAILED: Thermal config

[0000.514] E> FAILED: MEMIO rail config

[0000.532] I> Boot-device: eMMC

[0000.542] I> sdmmc bdev is already initialized

[0000.613] I> MB1 done

ÿýÿàmain enter

SPE VERSION #: R01.00.14 Created: Sep 19 2018 @ 11:03:21

HW Function test

Start Scheduler.

in late init

ÿâ
[0000.621] I> Welcome to MB2(TBoot-BPMP) (version: 00.00.2018.32-mobile-2dfe4beb)

[0000.622] I> DMA Heap @ [0x526fa000 - 0x52ffa000]

[0000.622] I> Default Heap @ [0xd486400 - 0xd48a400]

[0000.623] E> DEVICE_PROD: Invalid value data = 70020000, size = 0.

[0000.629] W> device prod register failed

[0000.633] I> Boot-device: eMMC

[0000.636] I> Boot_device: SDMMC_BOOT instance: 3

[0000.641] I> sdmmc-3 params source = boot args

[0000.644] I> sdmmc bdev is already initialized

[0000.649] I> sdmmc-3 params source = boot args

[0000.655] I> Found 17 partitions in SDMMC_BOOT (instance 3)

[0000.662] I> Found 42 partitions in SDMMC_USER (instance 3)

[0000.664] I> Active Boot chain : 1

[0000.667] I> parsing oem signed section of bpmp-fw header done

[0000.673] I> bpmp-fw binary init read from storage

[0000.678] I> oem authentication of bpmp-fw header done

[0000.684] I> bpmp-fw binary done read from storage

[0000.687] I> bpmp-fw: Authentication init Done

[0000.692] I> parsing oem signed section of cpubl header done

[0000.697] I> cpubl binary init read from storage

[0000.701] I> bpmp-fw: Authentication Finalize Done

[0000.706] I> oem authentication of cpubl header done

[0000.711] I> cpubl binary done read from storage

[0000.715] I> cpubl: Authentication init Done

[0000.720] I> parsing oem signed section of rce header done

[0000.725] I> rce binary init read from storage

[0000.729] I> Relocating BR-BCT

[0000.732] I> cpubl: Authentication Finalize Done

[0000.737] I> oem authentication of rce header done

[0000.741] I> rce binary done read from storage

[0000.745] I> rce: Authentication init Done

[0000.750] I> parsing oem signed section of ape header done

[0000.755] I> ape binary init read from storage

[0000.759] I> rce: Authentication Finalize Done

[0000.763] I> oem authentication of ape header done

[0000.768] I> ape binary done read from storage

[0000.772] I> ape: Authentication init Done

[0000.777] I> parsing oem signed section of tos header done

[0000.781] I> tos binary init read from storage

[0000.786] I> ape: Authentication Finalize Done

[0000.791] I> oem authentication of tos header done

[0000.794] I> tos binary done read from storage

[0000.799] I> tos: Authentication init Done

[0000.803] I> parsing oem signed section of bpmp-fw-dtb header done

[0000.809] I> bpmp-fw-dtb binary init read from storage

[0000.814] I> tos: Authentication Finalize Done

[0000.820] I> oem authentication of bpmp-fw-dtb header done

[0000.826] I> bpmp-fw-dtb binary done read from storage

[0000.828] I> bpmp-fw-dtb: Authentication init Done

[0000.833] I> parsing oem signed section of cpubl-dtb header done

[0000.839] I> cpubl-dtb binary init read from storage

[0000.844] I> bpmp-fw-dtb: Authentication Finalize Done

[0000.881] I> oem authentication of cpubl-dtb header done

[0000.882] I> cpubl-dtb binary done read from storage

[0000.882] I> cpubl-dtb: Authentication init Done

[0000.884] I> parsing oem signed section of eks header done

[0000.885] I> eks binary init read from storage

[0000.885] I> cpubl-dtb: Authentication Finalize Done

[0000.886] I> oem authentication of eks header done

[0000.890] I> eks binary done read from storage

[0000.894] I> eks: Authentication init Done

[0000.898] I> eks: Authentication Finalize Done

[0000.902] I> EKB detected (length: 0x410) @ VA:0x5270a400

ÿäNOTICE: BL31: v1.3(release):41d46a9cf

NOTICE: BL31: Built : 15:54:34, Aug 3 2020

ipc-unittest-main: 1519: Welcome to IPC unittest!!!

ipc-unittest-main: 1531: waiting forever

ipc-unittest-srv: 329: Init unittest services!!!

hwkey-agent: 40: hwkey-agent is running!!

hwkey-agent: 182: key_mgnt_processing …

hwkey-agent: 157: Init hweky-agent services!!

platform_bootstrap_epilog: trusty bootstrap complete

ÿâ

welcome to lk

calling constructors

initializing heap

creating bootstrap completion thread

top of bootstrap2()

initializing platform

bpmp: platform_init

tag is 57f8a77779f848bf2ecf21dabee5645f

tag_show initialized

dt initialized

mail initialized

chipid initialized

fuse initialized

sku initialized

speedo initialized

ec_get_ec_list: found 45 ecs

ec initialized

ec_mrq initialized

vmon_populate_monitors: found 3 monitors

vmon initialized

adc initialized

fmon_populate_monitors: found 73 monitors

fmon initialized

fmon_mrq initialized

reset initialized

nvhs initialized

392 clocks registered

WARNING: pll_c4 has no dyn ramp

clk_mrq_init: mrq handler registered

clk initialized

nvlink initialized

io_dpd initialized

io_dpd initialized

thermal initialized

i2c5 controller initialized

initialized i2c mrq handling

i2c initialized

regulator initialized

avfs_clk_platform initialized

soctherm initialized

aotag initialized

powergate initialized

dvs initialized

pm initialized

pg_late initialized

strap initialized

tag initialized

emc initialized

clk_dt initialized

avfs_ccplex_platform initialized

tj_max: dt node not found

tj_init initialized

uphy_mrq_init: mrq handler registered

uphy_dt initialized

uphy initialized

safereg_init: period 80 ms

ec_late initialized

mrq initialized

ÿá
[0001.407] I> Welcome to Cboot

ÿâfmon_post initialized

ÿá[0001.407] I> Cboot Version: t194-18fdfe28

[0001.407] I> CPU-BL Params @ 0xf2820000

[0001.408] I> 0) Base:0x00000000 Size:0x00000000

[0001.411] I> 1) Base:0xf1100000 Size:0x00100000

[0001.416] I> 2) Base:0xf2000000 Size:0x00200000

[0001.420] I> 3) Base:0xf1200000 Size:0x00200000

[0001.425] I> 4) Base:0xf1000000 Size:0x00100000

[0001.429] I> 5) Base:0xf0f00000 Size:0x00100000

[0001.434] I> 6) Base:0xf3800000 Size:0x00400000

[0001.438] I> 7) Base:0xf1c00000 Size:0x00400000

ÿâclk_set_parent failed for clk can1, parent pll_aon (-22)

clk_set_parent failed for clk can2, parent pll_aon (-22)

clk_set_parent failed for clk dmic5, parent pll_aon (-22)

clk_set_parent failed for clk i2c2, parent pll_aon (-22)

clk_set_parent failed for clk i2c8, parent pll_aon (-22)

clk_set_parent failed for clk spi2, parent pll_aon (-22)

clk_set_parent failed for clk pwm4, parent pll_aon (-22)

clk_dt_late initialized

machine_check initialized

pm_post initialized

dbells initialized

avfs_clk_platform_post initialized

dmce initialized

cvc initialized

ccplex_avfs_hw_init: nafll_cluster0: not monitored

ccplex_avfs_hw_init: nafll_cluster1: not monitored

ccplex_avfs_hw_init: nafll_cluster2: not monitored

ccplex_avfs_hw_init: nafll_cluster3: not monitored

avfs_clk_mach_post initialized

regulator_post initialized

rm initialized

sc7_diag initialized

thermal_test initialized

serial_late initialized

clk_post initialized

clk_dt_post initialized

mc_reg initialized

pg_post initialized

dyn_modules initialized

sku_debugfs initialized

speedo_debugfs initialized

adc_debugfs initialized

clk_debugfs initialized

ÿá[0001.443] I> 8) Base:0xf0e00000 Size:0x00100000

[0001.547] I> 9) Base:0xf0d00000 Size:0x00100000

[0001.552] I> 10) Base:0xf3000000 Size:0x00800000

[0001.556] I> 11) Base:0x40000000 Size:0x00040000

[0001.561] I> 12) Base:0xf0c00000 Size:0x00100000

[0001.565] I> 13) Base:0x40046000 Size:0x00002000

[0001.570] I> 14) Base:0x40048000 Size:0x00002000

[0001.574] I> 15) Base:0xac000000 Size:0x00004000

[0001.579] I> 16) Base:0x4004a000 Size:0x00002000ÿâemc_debugfs initialized

dvs_debugfs initialized

ÿá

[0001.588] I> 17) Base:0xf0b00000 Size:0x00100000ÿâfmon_debugfs initialized

vmon_debugfs initialized

pg_debugfs initialized

profile_fs initialized

debugfs_cons initialized

mail_fs initialized

profile initialized

cvc_debugfs initialized

dmce_debugfs initialized

ec_debugfs initialized

rm_debugfs initialized

soctherm_debug initialized

gr_reader initialized

mods initialized

dt_fs initialized

debugfs_mrq initialized

debug_mrq initialized

debug_safereg initialized

initializing target

calling apps_init()

starting app shell

entering main console loop

] ÿá

[0001.638] I> 18) Base:0x4004c000 Size:0x00002000

[0001.643] I> 19) Base:0xf2200000 Size:0x00600000

[0001.647] I> 20) Base:0x4004e000 Size:0x00002000

[0001.652] I> 21) Base:0xf09d0000 Size:0x0000c000

[0001.656] I> 22) Base:0x00000000 Size:0x00000000

[0001.661] I> 23) Base:0xf09e0000 Size:0x00020000

[0001.665] I> 24) Base:0xf6000000 Size:0x02000000

[0001.670] I> 25) Base:0x40050000 Size:0x00002000

[0001.674] I> 26) Base:0x40040000 Size:0x00006000

[0001.678] I> 27) Base:0xf1800000 Size:0x00400000

[0001.683] I> 28) Base:0xf4c00000 Size:0x01400000

[0001.687] I> 29) Base:0xf1400000 Size:0x00400000

[0001.692] I> 30) Base:0xf0a00000 Size:0x00100000

[0001.696] I> 31) Base:0x00000000 Size:0x00000000

[0001.701] I> 32) Base:0xf8000000 Size:0x08000000

[0001.705] I> 33) Base:0x00000000 Size:0x00000000

[0001.710] I> 34) Base:0xf3c00000 Size:0x01000000

[0001.714] I> 35) Base:0xab000000 Size:0x01000000

[0001.719] I> 36) Base:0xa0000000 Size:0x0b000000

[0001.723] I> 37) Base:0xf2800000 Size:0x00800000

[0001.728] I> 38) Base:0x80000000 Size:0x20000000

[0001.732] I> 39) Base:0xb0000000 Size:0x08000000

[0001.737] I> 40) Base:0x00000000 Size:0x00000000

[0001.741] I> 41) Base:0x00000000 Size:0x00000000

[0001.745] I> 42) Base:0x00000000 Size:0x00000000

[0001.750] I> 43) Base:0x00000000 Size:0x00000000

[0001.754] I> 44) Base:0x00000000 Size:0x00000000

[0001.759] I> 45) Base:0x00000000 Size:0x00000000

[0001.763] GIC-SPI Target CPU: 0

[0001.766] Interrupts Init done

[0001.769] calling constructors

[0001.772] initializing heap

[0001.775] I> Heap: [0xa06905a8 … 0xab000000]

[0001.779] initializing threads

[0001.782] initializing timers

[0001.785] creating bootstrap completion thread

[0001.789] top of bootstrap2()

[0001.792] CPU: MIDR: 0x4E0F0040, MPIDR: 0x80000000

[0001.796] initializing platform

[0001.799] E> DEVICE_PROD: Invalid value data = 0, size = 0.

[0001.805] W> device prod register failed

[0001.809] I> Bl_dtb @0xaaf00000

[0001.815] W> “plugin-manager” doesn’t exist, creating

[0001.816] W> “ids” doesn’t exist, creating

[0001.821] W> “connection” doesn’t exist, creating

[0001.825] W> “configs” doesn’t exist, creating

[0001.837] I> Find /i2c@3160000’s alias i2c0

[0001.837] I> Reading eeprom i2c=0 address=0x50

[0001.863] I> Device at /i2c@3160000:0x50

[0001.863] I> Reading eeprom i2c=0 address=0x56

[0001.888] I> Device at /i2c@3160000:0x56

[0001.890] I> Find /i2c@3180000’s alias i2c2

[0001.890] I> Reading eeprom i2c=2 address=0x54

[0001.892] E> I2C: slave not found in slaves.

[0001.892] E> I2C: Could not write 0 bytes to slave: 0x00a8 with repeat start true.

[0001.893] E> I2C_DEV: Failed to send register address 0x00000000.

[0001.893] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa8 at 0x00000000 via instance 2.

[0001.902] E> eeprom: Failed to read I2C slave device

[0001.907] I> Eeprom read failed 0x3526070d

[0001.911] I> Reading eeprom i2c=2 address=0x57

[0001.915] E> I2C: slave not found in slaves.

[0001.919] E> I2C: Could not write 0 bytes to slave: 0x00ae with repeat start true.

[0001.927] E> I2C_DEV: Failed to send register address 0x00000000.

[0001.932] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xae at 0x00000000 via instance 2.

[0001.942] E> eeprom: Failed to read I2C slave device

[0001.947] I> Eeprom read failed 0x3526070d

[0001.951] I> Reading eeprom i2c=2 address=0x52

[0001.955] E> I2C: slave not found in slaves.

[0001.959] E> I2C: Could not write 0 bytes to slave: 0x00a4 with repeat start true.

[0001.967] E> I2C_DEV: Failed to send register address 0x00000000.

[0001.973] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa4 at 0x00000000 via instance 2.

[0001.982] E> eeprom: Failed to read I2C slave device

[0001.987] I> Eeprom read failed 0x3526070d

[0001.992] I> Find /i2c@c240000’s alias i2c1

[0001.995] I> Reading eeprom i2c=1 address=0x52

[0002.000] E> I2C: slave not found in slaves.

[0002.003] E> I2C: Could not write 0 bytes to slave: 0x00a4 with repeat start true.

[0002.011] E> I2C_DEV: Failed to send register address 0x00000000.

[0002.017] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa4 at 0x00000000 via instance 1.

[0002.026] E> eeprom: Retry to read I2C slave device.

[0002.031] E> I2C: slave not found in slaves.

[0002.035] E> I2C: Could not write 0 bytes to slave: 0x00a4 with repeat start true.

[0002.043] E> I2C_DEV: Failed to send register address 0x00000000.

[0002.048] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa4 at 0x00000000 via instance 1.

[0002.058] E> eeprom: Failed to read I2C slave device

[0002.063] I> Eeprom read failed 0x3526070d

[0002.067] I> Reading eeprom i2c=1 address=0x50

[0002.071] E> I2C: slave not found in slaves.

[0002.075] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.

[0002.083] E> I2C_DEV: Failed to send register address 0x00000000.

[0002.089] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via instance 1.

[0002.098] E> eeprom: Retry to read I2C slave device.

[0002.103] E> I2C: slave not found in slaves.

[0002.107] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.

[0002.115] E> I2C_DEV: Failed to send register address 0x00000000.

[0002.120] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via instance 1.

[0002.130] E> eeprom: Failed to read I2C slave device

[0002.135] I> Eeprom read failed 0x3526070d

[0002.139] I> create_pm_ids: id: 2888-0004-400-K, len: 15

[0002.144] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93

[0002.155] I> create_pm_ids: id: 2822-0000-700-J, len: 15

[0002.160] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93

[0002.171] I> Adding plugin-manager/ids/2888-0004-400=/i2c@3160000:module@0x50

[0002.179] W> “i2c@3160000” doesn’t exist, creating

[0002.183] W> “module@0x50” doesn’t exist, creating

[0002.188] I> Adding plugin-manager/ids/2822-0000-700=/i2c@3160000:module@0x56

[0002.195] W> “module@0x56” doesn’t exist, creating

[0002.201] I> Adding plugin-manager/cvm

[0002.203] W> “chip-id” doesn’t exist, creating

[0002.207] I> Adding plugin-manager/chip-id/A02P

[0002.211] I> Plugin-manager override starting

[0002.217] I> node /plugin-manager/fragement-tegra-wdt-en matches

[0002.225] I> node /plugin-manager/fragement-soft-wdt matches

[0002.235] I> node /plugin-manager/fragment-pcie-c5-rp matches

[0002.240] I> node /plugin-manager/fragment-tegra-ufs-lane10 matches

[0002.256] I> Disable plugin-manager status in FDT

[0002.256] I> Plugin-manager override finished successfully

[0002.256] I> gpio framework initialized

[0002.258] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra194-gpio’ driver

[0002.261] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra194-gpio-aon’ driver

[0002.267] I> tegrabl_tca9539_init: i2c bus: 1, slave addr: 0x46

[0002.275] E> fetch_driver_phandle_from_dt: failed to get node with compatible ti,tca9539

[0002.283] E> fetch_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539

[0002.289] W> tegrabl_tca9539_init: failed to fetch phandle from dt

[0002.295] I> tegrabl_tca9539_init: i2c bus: 1, slave addr: 0x44

[0002.303] E> fetch_driver_phandle_from_dt: failed to get node with compatible ti,tca9539

[0002.311] E> fetch_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539

[0002.317] W> tegrabl_tca9539_init: failed to fetch phandle from dt

[0002.324] I> fixed regulator driver initialized

[0002.335] I> register ‘maxim’ power off handle

[0002.335] I> virtual i2c enabled

[0002.336] I> registered ‘maxim,max20024’ pmic

[0002.339] I> tegrabl_gpio_driver_register: register ‘max20024-gpio’ driver

[0002.345] I> Boot-device: eMMC

[0002.348] I> Boot_device: SDMMC_BOOT instance: 3

[0002.357] I> sdmmc-3 params source = boot args

[0002.357] I> create_pm_ids: id: 2888-0004-400-K, len: 15

[0002.362] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93

[0002.373] I> create_pm_ids: id: 2822-0000-700-J, len: 15

[0002.378] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93

[0002.389] I> sdmmc bdev is already initialized

[0002.394] I> sdmmc-3 params source = boot args

[0002.425] I> Found 17 partitions in SDMMC_BOOT (instance 3)

[0002.438] I> Found 42 partitions in SDMMC_USER (instance 3)

[0002.448] I> enabling ‘vdd-hdmi-5v0’ regulator

[0002.454] I> regulator ‘vdd-hdmi-5v0’ already enabled

[0002.454] I> hdmi cable connected

[0002.456] W> set volts not configured for ‘vdd-1v0’

[0002.459] W> set volts not configured for ‘vdd-1v8-hs’

[0002.463] E> invalid display type

[0002.468] E> invalid display type

[0002.469] E> cannot find any other nvdisp nodes

[0002.484] I> edid read success

[0002.497] I> edid read success

[0002.497] I> width = 640, height = 480, frequency = 25174825

[0002.497] I> width = 640, height = 480, frequency = 25174825

[0002.498] I> width = 1920, height = 1200, frequency = 154000000

[0002.498] I> width = 1920, height = 1080, frequency = 148500000

[0002.499] I> width = 1920, height = 1080, frequency = 148351648

[0002.503] I> width = 1280, height = 720, frequency = 74175824

[0002.509] I> width = 720, height = 480, frequency = 26973026

[0002.514] I> width = 720, height = 480, frequency = 26973026

[0002.520] I> width = 640, height = 480, frequency = 25174825

[0002.525] I> width = 1920, height = 1080, frequency = 148351648

[0002.531] I> width = 720, height = 576, frequency = 26973026

[0002.536] I> width = 1280, height = 720, frequency = 74175824

[0002.542] I> width = 1920, height = 1080, frequency = 74175824

[0002.548] I> width = 720, height = 576, frequency = 26973026

[0002.553] I> Best mode Width = 1920, Height = 1080, freq = 148351648

[0002.563] I> hdmi_enable, starting HDMI initialisation

[0002.568] I> hdmi_enable, HDMI initialisation complete

[0002.578] I> Load in CBoot Boot Options partition and parse it

[0002.585] E> Error -9 when finding node with path /boot-configuration

[0002.585] E> tegrabl_cbo_parse_info: “boot-configuration” not found in CBO file.

[0002.589] I> Hit any key to stop autoboot: 4 3 2 1

[0004.596] initializing target

[0004.596] calling apps_init()

[0004.597] starting app kernel_boot_app

[0004.616] I> found decompressor handler: lz4-legacy

[0004.617] I> decompressing BMP blob …

[0004.620] I> Kernel type = Normal

[0004.621] I> Loading kernel-bootctrl from partition

[0004.621] I> Loading partition kernel-bootctrl at 0xa4ac0000 from device(0x1)

[0004.628] W> tegrabl_get_kernel_bootctrl: magic number(0x00000000) is invalid

[0004.628] W> tegrabl_get_kernel_bootctrl: use default dummy boot control data

[0004.629] I> ########## SD boot ##########

[0004.633] I> No sdcard

[0004.635] I> -0 params source =

[0004.638] E> Blockdev open: exit error

[0004.641] E> SD boot failed, err: 724238353

[0004.645] I> ########## USB boot ##########

[0004.666] I> USB Firmware Version: 60.06 release

[0004.722] I> regulator of usb2-0 already enabled

[0004.730] I> regulator of usb2-1 already enabled

[0004.738] I> regulator of usb2-2 already enabled

[0004.747] I> enabling ‘vdd-5v-sata’ regulator

[0005.752] E> failed to initialize xhci controller

[0005.753] E> Error in init of XUSB host driver, err: 79790026

[0005.753] E> Failed to initialize device 5-0

[0005.754] E> USB boot failed, err: 2037973030

[0005.754] I> ########## Fixed storage boot ##########

[0005.754] I> Already published: 00010003

[0005.755] I> Look for boot partition

[0005.758] I> Fallback: assuming 0th partition is boot partition

[0005.764] I> Detect filesystem

[0005.791] I> Loading extlinux.conf …

[0005.791] I> rootfs path: /sdmmc_user/boot/extlinux/extlinux.conf

[0005.828] I> L4T boot options

[0005.828] I> [1]: “primary kernel”

[0005.828] I> Enter choice:

[0008.830] I> Continuing with default option: 1

[0008.830] I> Loading kernel sig file from rootfs …

[0008.830] I> rootfs path: /sdmmc_user/boot/Image.sig

[0008.849] I> Loading kernel binary from rootfs …

[0008.849] I> rootfs path: /sdmmc_user/boot/Image

[0009.092] I> Validate kernel …

[0009.092] I> T19x: Authenticate kernel (bin_type: 37), max size 0x5000000

[0009.404] E> digest on binary did not match!!

[0009.404] C> OEM authentication of kernel payload failed!

[0009.405] W> Failed to validate kernel binary (err=1077936152, fail=0)

[0009.405] W> Security fuse not burned, ignore validation failure

[0009.412] I> No kernel-dtb binary path

[0009.419] I> A/B: bin_type (38) slot 1

[0009.420] I> Loading kernel-dtb_b from partition

[0009.420] I> Loading partition kernel-dtb_b at 0x91000000 from device(0x1)

[0009.430] I> Validate kernel-dtb …

[0009.431] I> T19x: Authenticate kernel-dtb (bin_type: 38), max size 0x400000

[0009.435] I> Loading ramdisk from rootfs …

[0009.435] I> rootfs path: /sdmmc_user/boot/initrd

[0009.492] I> Kernel hdr @0xa4ac0000

[0009.493] I> Kernel dtb @0x90000000

[0009.493] I> decompressor handler not found

[0009.493] I> Copying kernel image (34330632 bytes) from 0xa4ac0000 to 0x80080000 … [0009.503] I> Done

[0009.504] I> Updated bpmp info to DTB

[0009.506] I> Ramdisk: Base: 0x92000000; Size: 0x54ecaf

[0009.506] I> Updated initrd info to DTB

[0009.506] W> WARN: Fail to override “console=none” in commandline

[0009.507] E> tegrabl_linuxboot_add_disp_param, du 1 failed to get display params

[0009.513] E> tegrabl_linuxboot_add_disp_param, du 1 failed to get display params

[0009.520] I> Active slot suffix: _b

[0009.523] I> add_boot_slot_suffix: slot_suffix = _b

[0009.528] I> Linux Cmdline: console=ttyTCU0,115200 video=tegrafb no_console_suspend=1 earlycon=tegra_comb_uart,mmio32,0x0c168000 gpt tegra_fbmem=0x800000@0xa069c000 lut_mem=0x2008@0xa0697000 usbcore.old_scheme_first=1 tegraid=19.1.2.0.0 maxcpus=8 boot.slot_suffix=_b boot.ratchetvalues=0.4.2 vpr_resize sdhci_tegra.en_boot_part_access=1

[0009.558] I> Updated bootarg info to DTB

[0009.562] W> MAC addr invalid!

[0009.564] E> Failed to get WIFI MAC address

[0009.568] W> MAC addr invalid!

[0009.571] E> Failed to get Bluetooth MAC address

[0009.576] I> eeprom_get_mac_addr: MAC (type: 2): 00:04:4b:e5:a0:c4

[0009.583] W> “plugin-manager” doesn’t exist, creating

[0009.587] I> Adding /chosen/plugin-manager/cvm

[0009.591] W> “chip-id” doesn’t exist, creating

[0009.595] I> Adding /chosen/plugin-manager/chip-id

[0009.600] W> “configs” doesn’t exist, creating

[0009.604] I> Adding /chosen/plugin-manager/configs

[0009.609] W> “ids” doesn’t exist, creating

[0009.613] I> Adding /chosen/plugin-manager/ids

[0009.618] W> “odm-data” doesn’t exist, creating

[0009.622] I> Adding /chosen/plugin-manager/odm-data

[0009.629] W> “memory” doesn’t exist, creating

[0009.631] I> [0] START: 0x80000000, END: 0xac000000

[0009.635] I> [1] START: 0xac004000, END: 0xf09d0000

[0009.640] I> [2] START: 0xf09dc000, END: 0xf09e0000

[0009.645] I> dram_block larger than 80000000

[0009.649] I> [3] START: 0x100000000, END: 0x880000000

[0009.654] I> added [base:0x80000000, size:0x2c000000] to /memory

[0009.659] I> added [base:0xac200000, size:0x44600000] to /memory

[0009.665] I> added [base:0x100000000, size:0x780000000] to /memory

[0009.672] I> Updated memory info to DTB

[0009.675] E> add_disp_param: failed to get display params for du=1

[0009.682] W> “reset” doesn’t exist, creating

[0009.686] I> NVG: Logical CPU: 0; MPIDR: 0x80000000

[0009.690] I> NVG: Logical CPU: 1; MPIDR: 0x80000001

[0009.695] I> NVG: Logical CPU: 2; MPIDR: 0x80000100

[0009.699] I> NVG: Logical CPU: 3; MPIDR: 0x80000101

[0009.704] I> NVG: Logical CPU: 4; MPIDR: 0x80000200

[0009.709] I> NVG: Logical CPU: 5; MPIDR: 0x80000201

[0009.714] I> NVG: Logical CPU: 6; MPIDR: 0x80000300

[0009.718] I> NVG: Logical CPU: 7; MPIDR: 0x80000301

[0009.724] W> “misc-data” doesn’t exist, creating

[0009.728] I> Boot-device: eMMC

[0009.730] I> Add boot-sdmmc to plugin-manager/misc-data

[0009.736] I> Add storage-sdmmc to plugin-manager/misc-data

[0009.741] W> Unknown storage device

[0009.744] I> Add serial number:1421220031673 as DT property

[0009.751] I> Plugin-manager override starting

[0009.754] I> node /plugin-manager/fragement-tegra-wdt-en matches

[0009.762] I> node /plugin-manager/fragement-soft-wdt matches

[0009.769] I> node /plugin-manager/fragment-pcie-c5-rp matches

[0009.774] I> node /plugin-manager/fragment-tegra-ufs-lane10 matches

[0009.785] I> Disable plugin-manager status in FDT

[0009.785] I> Plugin-manager override finished successfully

[0009.787] I> tegrabl_load_kernel_and_dtb: Done

[0009.837] I> Kernel EP: 0x80080000, DTB: 0x90000000

[ 0.000000] Booting Linux on physical CPU 0x0

[ 0.000000] Linux version 4.9.140-tegra (buildbrain@mobile-u64-3357) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #1 SMP PREEMPT Thu Jun 25 21:22:12 PDT 2020

[ 0.000000] Boot CPU: AArch64 Processor [4e0f0040]

[ 0.000000] OF: fdt:memory scan node memory, reg size 48,

[ 0.000000] OF: fdt: - 80000000 , 2c000000

[ 0.000000] OF: fdt: - ac200000 , 44600000

[ 0.000000] OF: fdt: - 100000000 , 780000000

[ 0.000000] earlycon: tegra_comb_uart0 at MMIO32 0x000000000c168000 (options ‘’)

[ 0.000000] bootconsole [tegra_comb_uart0] enabled

[ 0.000000] Found tegra_fbmem: 00800000@a069c000

[ 0.000000] Found lut_mem: 00002008@a0697000

ÿâWARNING: pll_d3 has no dyn ramp

ÿá[ 5.584394] cgroup: cgroup2: unknown option “nsdelegate”

[ 6.772641] iwlwifi 0003:01:00.0: Direct firmware load for iwlwifi-8265-26.ucode failed with error -2

[ 6.772912] iwlwifi 0003:01:00.0: Falling back to user helper

[ 6.918099] random: crng init done

[ 6.918257] random: 7 urandom warning(s) missed due to ratelimiting

[ 7.294717] iwlwifi 0003:01:00.0: Direct firmware load for iwlwifi-8265-25.ucode failed with error -2

[ 7.294958] iwlwifi 0003:01:00.0: Falling back to user helper

[ 7.298291] iwlwifi 0003:01:00.0: Direct firmware load for iwlwifi-8265-24.ucode failed with error -2

[ 7.298553] iwlwifi 0003:01:00.0: Falling back to user helper

[ 7.299499] iwlwifi 0003:01:00.0: Direct firmware load for iwlwifi-8265-23.ucode failed with error -2

[ 7.299740] iwlwifi 0003:01:00.0: Falling back to user helper

[ 7.534669] thermal thermal_zone8: failed to read out thermal zone (-5)

[ 11.685304] using random self ethernet address

[ 11.685478] using random host ethernet address

[ 12.158622] using random self ethernet address

[ 12.158799] using random host ethernet address

At the moment yes, we only have one xavier.
We are using https://github.com/wilicc/gpu-burn to reproduce the problem.

The timestamp looks like the temperature rises to 56C in < 2 min. Are you able to enable the fan and see if the issue is still?

Yes I will try, maybe the xavier was still warm from a previous boot.

Yes I still have the same issue when the fan is on. I should add that this shutdown happens only when using the MAXN mode, (it’s fine in 30W ALL) and it happens almost instantly when I run the gpu stress test command.

Hi,

I notice you said “using 14V battery”. Could you try to use the power adapter ?

Hi,
I could but I know it works fine, that is the problem. We can’t use the power adapter since we need the system to be portable.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

“I notice you said “using 14V battery”. Could you try to use the power adapter ?”
This suggestions is to clarify if that’s battery issue.