Crash/Power off with Mobile Linux Drivers on an NVidia GeForce 640m LE (Sony Vaio 13SVS with Gentoo)

Hello, I have an NVidia GeForce 640m LE on a Sony Vaio 13SVS. The problem is when I try to run my nvidia card on Linux Gentoo. I have tried different kernels, the last one 3.12.21-r1. I have also tried with the latest nvidia drivers, at the time, v340.32. I experience the following problem. Each single time I try to load the nvidia driver, both modprobe or using optirun/bumblebee, the computer power off. It doesn’t seem to be a problem with the hardware as with Windows it seems to run fine. I have recompiled kernel and drivers to be consistent (even did it several times). Always the same problems. It also happens with older kernels and older versions of the nvidia driver.

Xorg log’s doesn’t seem to provide much information.

Please, I would be really interesting in using my nvidia hardware in my developer environment (Linux Gentoo). Is there any patch/solution for this issue, thank you in advance.


I’m having this problem too on Debian Jessie and in Ubuntu 14.04LTS. Anyone got an idea on how to solve this?