Cuda 1.0 where it should have 2.0 instead installation-problem

I installed 178.08 Cuda driver from the off. site on my P4 3.4GHz with a 8800 GTS 640 MB.
It should support Cuda 2.0.
But according to the SDK BROWER, I only can run 1.0 applications.
Even 1.1 applications refuse.
Before 178.08 I had 178.24, didn’t also manage to run Cuda 2.0 applications.

damned: http://www.gpugrid.net/forum_thread.php?id=316