Driver compatibility?

Hi.

I wonder if there are some driver compatibility problems with CUDA 2.0.

My graphics card is 8800 GTX and I have been using CUDA 2.0 beta on the driver 177.35. (in XP)

I have written my code which runs well with the 177.35 driver, and found that there are updates of a driver and CUDA yesterday.

After I updated the device driver to 178.28 (and I also tried 180.60 available in the CUDA download page), the code I wrote does not run well.

It gives “unspecified launch failure” error (I think it comes from the cudaMemcpy2DToArray statement.) and many other messages like
“First-chance exception at 0x7c812a5b in tracker_debug.exe: Microsoft C++ exception: cudaError_enum at memory location” when I run it in Debug mode.

When I roll the driver back to 177.35, it runs well again. Thus, I wonder this is the driver compatibility problem.

Is there anybody who has or solves the same problem?

I dug this forum for a while but I can not find any post about this.

Any comment or idea is welcome.

180.60 is the CUDA 2.1 beta driver. You likely have to install the CUDA 2.1 beta toolkit and recompile your code.