CUDA 2.0 for Mac OS X is out

CUDA 2.0 is available from CUDA Zone.

Hello,
Is it just me, or the cuda driver (/usr/local/cuda/lib) of MacOS 10.5.4 is not compatible with Cuda 2.0 ? The demos only work in emulation mode.
I am on a MBP with a GeForce 8600M GT.

Regards,
Chacha

Have you installed the new Toolkit?
It works fine on my MBP with 10.5.4.

Hello,

I’m using a mac with the 512MB 8800 GT, 2GB memory, and 10.5.2 OS X,
most of sample codes from CUDA 2.0 are running but not passing the self-test
or showing no expected results. For example, when I execute ‘imageDenoising’,
display window pops up but there is no response for keyboard input except ‘esc’ or ‘q’ key. (I can see the original image, though.)
In ‘simpleStream’, I got the message of bus error.

Is this just my case? Any help will be very appreciated.
Thanks a lot in advance.

=====
After posting this, I found that all sample codes are running on CPU, but I don’t know why it is, because I compiled them with “make dbg=1” or “make” command.
Please help me :fear:

Regards,
mya

Sure.

The problem is not that the demos do not compile or run -they do- but they are not doing what is expected. For instance, image denoising do not denoise, particles do not move, etc.

Regards

[edit]

I just see that apple is provided links to that CUDA release, (http://www.apple.com/downloads/macosx/deve…nvidiacuda.html), but they are claiming that it is a beta. What does that mean ? Isn’t it a normal release ?

Hi,

I have installed the 2.0 toolkit and 2.0 examples on three machines, a 4GB RAM, MacPro GeForce 8800 GT, and two MacBook Pro machines each with 4GB RAM and 8600M GT. All machines run OSX 10.5.4. Only one of the MacBook Pros works properly running all of the example CUDA programs. The others compile everything OK, but at runtime the applications seem to bring up the initial window, and blink a bit, but not proceed with any calculations. The example programs only respond to quit.

The only difference I can see is that Apple XCode 3.0 is on the machine that work, whilst XCode 3.1 is on the machines that don’t.

Now I am in a bit of a bind, since 3.0 tools are no longer downloadable from Apple via the Internet.

Does anyone out there have 2.0 toolkit and examples running with XCode 3.1?

Tony

I’ve installed Xcode 3.1 and cuda 2.0. The examples build and run correctly for me using gcc-4.2.

ok let’s me give you the clue about your problems. I have noticed that from my previously installed CUDA 1.1 the CUDA.kext driver was not updated during the CUDA 2 install. To check if you are in the same case just look at /System/Library/Extensions, if you still have 1.1 driver you ll see an install date of february instead of a desired one of july for the 2.0 build. So just reinstall it and click personnalize and do not forget to click on the cuda driver that ll shows an update status.

hope this ll help most of you

It worked. In my case, since I did never install CUDA 1.1, CUDA.kext was not even there. Indeed, when reinstalling I saw that CUDA.kext is not checked by default by the installer (how strange).

Thanks a lot, garcimore, you’re a magician !

Regards,

Pierre Chatelier

Actually this worked for me too. Now I have CUDA running on all 3 machines.

Tony

What exactly do you reinstall? Neither the toolbox nor the SDK seem to install CUDA.kext and there is no box to check for CUDA.kext I could find. Thanks! Jan Mandel

CUDA.kext is installed by the toolkit.
Which OS version are you running?

I m running MacOS 10.5.4 on MacBookPro.

I do not know if they have changed the pkg, but here is my experience :

-I had never installed any CUDA version before

-After installing SDK and Toolkit, it did not work. The kext was not installed (I ran a find command)

-I relaunched the Toolkit installation

-At the “Custom” stage, I entered the Customization, and saw that the CUDA.kext was not checked by default ; I checked it

-I finished the installation

-It asked me to relaunch ! (It did not at my first installation; this is all very logical, now)

-I relaunched, it worked.

Regards,

Thanks Chacha,

Everything just works now :)

Not sure what’s going on with CUDA.kext–can everyone who’s experienced the problem tell me if they’re using non-English languages by default? I’m wondering if it’s a localization issue.

my osx versions is a french 10.5.4 with a previous install of CUDA 1.1 on it on a macpro

I installed it in a Macbook pro with spanish leopard.

region=US language=English

I’m something of a Mac newbie, so this is probably a foolish question, but do I need to uninstall my Cuda 1.1 toolkit or SDK before I can install the shiny new 2.0 toolkit and SDK? If so, how do I go about doing this? I can’t find an uninstaller in any obvious place.

Thanks,
Jason

you can install it directly over 1.1