CUDA kext not installing

Whenever I run: kextstat | grep CUDA nothing happens. When I run ./devicequery , I only get Device Emulation (CPU). I did not see any customization options in the install that I have been reading about. All I seem to be able to do is change the install location.

I should probably add that I am running 10.5.7 with CUDA 2.2 on a 13 in Macbook with the Geforce 9400m.

It is there, in the toolkit installation
CUDA_Install_1.tiff (92.3 KB)

CUDA_Install_2.tiff (161 KB)

mfatica - please note that despite these instructions and the fact that the kext is checked, the kext is simply NOT loading for some people under 2.2. I have now found a similar problem with the 2.3beta and have gone back to a 2.2 kext that a pal with Quadro gave me as the your web file/installer did not work for me either. Please can Nvidia fix asap? I wonder if your installers are all reliably setting the kext permissions?

I saw that kext was in the package, but I did not see any option in the installer for it. Should I just uninstall 2.2 and install 2.1 instead? Is there a version that everybody can verify installs well?

I suggest you try any version you can get your hands on that gets an answer from that kextstat command I suggested. There is something odd going on with the kext installer. The only 2.2 version that always seems to work was on the disk that shipped with the Quadro. Other people have found that the online installer for 2.2 is OK, but I never got it to work. By all means try 2.1 to get going, but note that with some earlier versions you had to manually check the box to install the kext - that was an altogether separate problem!

Same problem here. Brand new Mac Pro with a 285. toolkit2.2 would not install by default the kext, took me a while to discover the “customize install” button and then I found that the kext toggle button was unchecked by default. Installed it and got nonsensical results. Went back to 2.1. Still nonsensical results.

Will try some more and if still not working will be back and beg for help.

I got it working how. I did not see the customize button, and sure enough it was not checked.

Can anyone say if the “customize” button exists in any of the 2.3 installs? I am seeing the behavior described in this thread, but am using 2.3. I have run the toolkit and driver installs several times and I do not see the “customize” button anywhere, but I may be looking in the wrong places. Can anyone advise?

There is a bug in the 2.3 installer: if you install the driver first and then the toolkit, the toolkit installation will remove cuda.dylib and your code will not work.
You can install the toolkit first and then the driver, or do driver/toolkit/driver.

I had installed toolkit and driver a few times each in various sequence without luck. I think that what finally worked was to install toolkit 2.2, then toolkit 2.3, then driver.