CUDA Environmental Variables Problem

I am having trouble setting the environmental variables for CUDA. I am running OS X 10.5.7 with CUDA 2.2 on a 13 in Macbook with the GeForce 9400M.

When I run the CUDA Profiler from finder I see the following Environmental Variables set:

DYLD_LIBRARY_PATH /usr/local/cuda/lib
PATH /usr/local/cuda/bin

These were the values I was told to use from the quick started guide.

I put those in an environment.plist file in my ~/.MacOSX folder. They showed up in the profiler automatically after I created this file, but I am still getting the following error: “Unable to initialize CUDA. CUDA Visual Profiler device features will be disabled.”

Is there something else I am forgetting to do. I have installed the toolkit and SDK already in that order.

These are very basic checks, but might be an idea to first check your CUDA kext is installed properly in /System/Library/Extensions by running (in a terminal)

kextstat | grep CUDA

which should return some stuff including com.nvidia.CUDA. If this is not there you need to re-install. There have been some issues with the kext not loading on some Macs but not others - maybe fixed now (?)

Once that is OK: Next, try running your settings manually. I do this in a script right now but do something like

cd /Developer/Cuda/bin/darwin/release

export DYLD_LIBRARY_PATH=/usr/local/cuda/lib:$DYLD_LIBRARY_PATH

export PATH=/usr/local/cuda/bin:$PATH

and try


This is all obvious stuff of course. I am assuming you ran make from /Developer/CUDA first.

I think I am in bigger trouble than I thought. I do not have the folder:


I looked for any release folder, and I also did not have devicequery.

What could I have done wrong? I installed the toolkit, set up the environmental variables, then I installed the SDK. I am trying to use CUDA 2.2 on OS X 10.5.7. I checked for software updates, and I did not have any.

Try setting DYLD_LIBRARY_PATH to /usr/local/cuda/lib:$DYLD_LIBRARY_PATH.