CUDA driver version is insufficient for CUDA runtime version on Jetson TX2

I’m running into an issue where I’ve installed cuda 8.0 and then later cuda 9.0 but when I run deviceQuery for cuda 9.0, it gives me the above error. Apparently, it only finds the cuda drivers for 8.0 and not the 9.0 and changing the path and ld_library_path doesn’t affect this. Does anybody know how to change the environment so it uses the cuda 9.0 device drivers? This is on the Jetson TX2 board btw so a lot of the commands for querying and checking this on standard linux hosts doesn’t apply here. Thanks!

you need to install the jetpack and use whatever driver comes with it. You don’t install drivers separately on Jetson.

The latest production Jetpack 3.1 has CUDA 8.

To get to cuda 9, you would have to install the developer preview jetpack 3.2

I have Jetpack 3.2 and wish to install CUDA 9.0 on my TX2, but reflashing the OS is not an option at this time. I was able to use the repository .deb files that Jetpack 3.2 downloaded to manually install the CUDA 9.0 toolkit without connecting directly to the device. I can build the samples, however when running them, I too get this error message stating that the CUDA driver version is insufficient.

Is there any way to update the drivers on the device without wiping the root filesystem? I can blow away /usr and /var if necessary, but not /etc or /home. Thanks!

you might want to ask such questions on the jetson forums

https://devtalk.nvidia.com/default/board/139/jetson-embedded-systems/

Good call, I didn’t check the location of the original post. Thanks for a timely response!

I’ve reposted my question with additional information here:
https://devtalk.nvidia.com/default/topic/1030219/jetson-tx2/installing-cuda-9-without-flashing/