cuda driver version is insufficient for cuda runtime version

Hi,

I have devices (Jetson TX2) that were flashed with Jetpack 3.3.2 that I need to update TENSORRT on. I made updates to the devices using the packages from the SDK manager:

  • CUDA 9 -> 10
  • CUDNN 7.1.5 -> 7.6.3
  • TENSORRT 4.0.2 -> 6.0.1

When I rebuild opencv and run my application on the devices, I get the error “cuda driver version is insufficient for cuda runtime version”. I need to be able to run the new version of TENSORRT on these devices without manually re-flashing Jetpack for my clients. Is there any way for me to remotely update the drivers via a software update or run a container on the devices with the old drivers that contains the new drivers? I have arm processor and need to use ubuntu1604 with cuda 10

Kind regards,
Wyatt

Unfortunately the CUDA version is tightly coupled to the operating system release (there are a lot of dependencies there). As a result you can only use the CUDA release which matches the same JetPack/SDK Manager install release. Ubuntu 16.04 will not be able to use newer CUDA releases.

I was able to get cuda 10 working using the L4t image (ubuntu1804): https://ngc.nvidia.com/catalog/containers/nvidia:l4t-base/tags

Are there any plans to release a version for Ubuntu 1604?

I am not an authoritative source on that, but from what I know, no backwards compatible releases will occur. You’re pretty much limited to using CUDA 10 with Ubuntu 18.04 and not 16.04.